16.04 failed to load Braiille support and kernel modules

Everyone else seems to have a working system despite these errors. Me, I get a reboot sometimes, and then my screen turns off. Once I got a mate splash screen.

Both the red and green led lights are constant on, don’t know if that helps. But I’ve been fighting with this computer for two days, and it’s supposed to be so easy kids can use it. Not doing much for my self esteem.

it says “see systemctl status systemd-modules-load.service for details”

edit. It’s dropping to the command prompt and I read the log file but can’t really figure out why it’s doing what it’s doing. Also I’m getting some bad block errors even though the system is checking the disk everytime it reboots. Also when i moved the sdcard back to my computer to retrieve the log file, it wasnt there anymore.

I do not run arm architecture, but systemctl is common to a standard desktop (amd/intel) install. Its a terminal command you need to run.
systemctl status systemd-modules-load.service

Hi @Evil-Wayz,

have you run a full system update which may solve the problem for you?:

I’d love to do a full system update. It stopped letting me go tot he command prompt. So I bought a pre installed card. And imagine my surprise when it does the exact same thing. I dont see how it can load without any kernel modules anyways.

I’ve also tried manually editing and commenting out all of cups, as per another thread I read on this subject

New development, i plugged my cell phone charger in to the pi and fired it up, and it got all the way to the desktop. I went to try and open terminal and it rebooted. This happened 5 times before he shutdown and my screen turned off.

Hi @Evil-Wayz,

try running “dpkg” per the update guide in recovery mode and see if that fixes the problem?:

You can also try running the following commands:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

Restart if anything updates at all!. :smiley:

how do I get to recovery mode? There’s no grub2 screen that I can see. And I can’t open a terminal before the board reboots. I think what I have here is the perfect storm, a bad board combined with a faulty power supply.

edit: HAng on I just figured out that they mean up arrow and shift, not just shift. I’ll be back with a report.

oK shift up doesnt do anything. However, I was able to drop to a console by using ctrl alt f1. I got the system to update using sudo apt update. But I can’t get it to upgrade, or full-upgrade before it reboots again. I tried, like eight times in a row, it gets as fas as reading the state info and then reboots.

My guess is its overheating, or it’s just bad. This is one of the ones made in PRC, not the UK, so I’m guessing the problem might very well be its a Taiwanese POS.

EDIT: Would it be possible for me to mount the sdcard, chroot and update it from a working linux box?

Hi @Evil-Wayz,

I don’t know about using an SD card (maybe @Wimpy or @lah7?) but you can get a full GRUB menu (I assume this works on Raspi too?) using the following info:

Just to note: The Raspberry Pi does not use GRUB for its bootloader. The Pi’s firmware starts itself up.

Most likely the case, since you’ve tried various cards to the same results. It could alternately be a power issue. The cards will end up corrupt if the power keeps forcing it to reboot abruptly.

So if it’s not a Raspberry Pi manufactured from the UK, is it a knock off clone? :confused:

1 Like

It came with all the correct packaging, but close inspection of the board reveals “Made in PRC.” As far as I know, genuine raspberry pi boards are made exclusively in the UK. I’ve bought a new board directly from one of the vendors listed on raspberrypi.org, hopefully I will have better luck with that.