17.04 Ubuntu-Mate install goes bad

I decided to try Ubuntu-Mate . The existing system had only one SSD with Windows 10. I installed a 2nd SSD just for the Linux system. However, should I boot into Linux the mouse moves but I get no response from button press; same with keyboard. I repeated the install several times wanting to blame Grub. The selection of which partition should receive Grub confused me so I tried sdb, then sda, but same problem.

I then disconnected the cable to the Windows 10 SSD and did a simpler install using the same memory chip in a multi-format USB drive—same result but install went to sda as expected…
Wanting to test if my SSD suddenly went bad, I swapped the Linux chip with a Windows 10 chip but now it installed ok. So, it’s not the SSD. I tested the downloaded ISO for errors and it passed the test so maybe Rufus (used to create a bootable usb with Ubuntu-mate 64bit) is at fault.

Side note: I read that Ubuntu will be without Unity so I was looking for Ubuntu with Gnome. I chose Mate instead of Gnome because of favorable ratings, but I have an i5-6500 processor with 16GB ddr4. Ubuntu-Mate is described as an OS for older machines. Wondering if since Canonical is dropping Unity for Gnome should I best prepare myself for a Gnome invironment?

did a simpler install using the same memory chip in a multi-format USB drive[/quote]Chip?[quote="bupkus, post:1, topic:13412"]
I swapped the Linux chip with a Windows 10 chip[/quote]Again, chip? What do you mean by chip in this context?[quote="bupkus, post:1, topic:13412"]
so maybe Rufus (used to create a bootable usb with Ubuntu-mate 64bit) is at fault.
[/quote]If Ubuntu is booting but simply, like before, not listening to mouse and keyboard then Rufus is not at fault. You see, if Rufus somehow managed to incorrectly write the bootable USB then you would not even be able to boot that USB.[quote="bupkus, post:1, topic:13412"]
Wondering if since Canonical is dropping Unity for Gnome should I best prepare myself for a Gnome invironment?[/quote]Well, there are many flavours to Ubuntu.

1 Like

I’m unfamiliar with the formatting of replies to specific text so I’ll just begin:
The keyboard and mouse I use are not wireless working off the same usb adapter.
The keyboard is a wired usb type by Logitech. The mouse is a Logitech wireless.
Both devices work very well with all other OS’s mostly Microsoft Windows.

The chips I refer to are SanDisk microSD memory modules I use inside a USB adapter.
Perhaps I should suspect this.

I have another usb adapter that accepts sata disks. I think I’ll use this to install U-mate to an old laptop hdd and try to boot using this off of each of my desktops. That may reveal something.

Thanks for your reply. I’ll LYK my results.

[quote=“bupkus, post:3, topic:13412”]Thanks for your reply.[/quote]The fact the mouse and keyboard work fine in Windows says nothing. I can show you an example in reverse – this PC. If I install Windows on this one, almost nothing works.

Point being – Something working in one OS does not guarantee it working correctly in another OS.

So, let me ask you something – Did you actually get to see Ubuntu run? As in, did it actually boot properly? I’m still not sure when you run into issues. If it did in fact boot properly then I can basically guarantee you the issue is the mouse and keyboard. If it did not boot properly then, well, we’ll have to keep looking.

You may also want to try 16.10. Maybe there is a specific problem of 17.04 on your machine.

If feasible you could just try a simple ps2 mouse and keyboard?

See the following for a wireless solution -

https://pwr.github.io/Solaar/

Pre-built packages are available for a few Linux distros.

Ubuntu/Kubuntu 12.04+: ppa:daniel.pavel/solaar

worked quite well for both a unifying receiver and a couple of other Logi receivers. One was a simple Logi scrolling mouse. Perhaps Logitech has a keyboard driver also?

Edit: See -

https://mikebeach.org/2010/06/27/logitech-devices-on-ubuntu-linux-and-others/

for a possible solution.

You didn’t mention anything about your hardware, but I think this may be a hardware issue. I have a Gigabyte motherboard and AMD cpu, and had the same problem when I first installed Ubuntu - some of my USB ports worked and others didn’t. The problem for me was an iommu issue. I think that there is some documentation on the Ubuntu wiki about this. Let me tell you my experience, and then tell you what I think will work if I had it to do over again:

  1. I installed Ubuntu Mate with iommu enabled in bios, but some of my USB ports would not work. I had to move my keyboard and mouse USB connectors around until I found two ports that were working.
  2. I went on like this for a while, but my USB 3.0 ports never worked. I did some research and found out that it’s an iommu issue. I added “iommu=soft” to ‘GRUB_CMDLINE_LINUX=’, ran sudo update-grub, rebooted and disabled iommu in bios.
  3. If you cannot get your keyboard working this will be impossible to do. What I would try in your case is to reboot. Go into bios and disable iommu. Save your changes and exit. When you get past the bios screen - press and hold the SHIFT key to enter grub. Press e to edit the grub menu. Look for the line that begins with linux. Somewhere towards the end of that line you should see quietsplash or nomodeset. Just before or after whichever or both of these commands which are present, enter iommu=soft. Save and continue to boot up. Your USB ports should now be working.
  4. If step (3) works for you, you will still need to go back and perform step (2). Otherwise, you will have to go into grub every time you boot up.

Since you are dual-booting with Windows 10, I have no clue what these changes will do to the operation of that system.

This is what worked for me when my USB ports weren’t working.

1 Like