18.04.3 Update caused problems with display (Nvidia)

I just updated my backup system (18.04.3) and my display (1920x1080) went into 800x600 mode and I am unable to correct. In the control panel the display shows as unknown and I can't change any settings. It has an Nvidia Quadro 600 graphics card.

I booted into Clear Linux and Ubuntu on other drives and everything was fine. I changed the Quadro out with a Radeon RX 460, booted into the original UM disk and everything was back to normal.

I installed Ubuntu Mate 18.04.3 onto a different drive. The installation program looked fine (I checked the box to install updates during the installation). When I rebooted to the fresh installation, I had the same 800x600 problem.

Is there something recent with UM that has changed to cause this problem with Nvidia? Is there something with the configuration I can try? All of my other machines with UM aren't experiencing this (none have Nvidia graphics). I keep my back up machine up to date, roughly weekly so this seems to be recent.

1 Like

Welcome mdd12. Sorry that you are having issues.

There was a an update to the HWE this week that updated the kernel to a 5.3x kernel.
Can you run the following and give us the output:
uname -a

In addition can you open Software & Updates click on the Additional Drivers tab and take a screen shot of that and upload that here. You can take a screenshot of the open windows using alt + PrtScn

Thanks for the reply.

uname -a

Linux HP-Z220 5.3.0-26-generic #28~18.04.1-Ubuntu SMP Wed Dec 18 16:40:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I tried the X Server but it didn't help. I haven't tried the 340 driver yet.

Also, I wrote too soon concerning the Ubuntu (18.04.3) installation. It too is giving me the same problem.

Hope this helps to diagnose what to do. Thanks again

Doing more research shows that it was indeed the kernel update. I went into Advanced options at the grub start up screen (ESC key) and chose the 5.0 kernel and everything seems normal.

There's also a discussion on the Linux Mint forum with some suggestions for solving the problem. I was able to get it to work with the new kernel on my Ubuntu disk though there are warnings and errors. I'm not sure how I got there as the suggestions didn't seem to work so I just tried variations of what they were doing, and as I was about to give up, it worked (don't really care if the installation gets hosed since it's on a spare disk). It seems there's an update to the 390 driver but didn't make it to the normal update/upgrade process.

I don't want to mess with my U-Mate disk for now and I'll wait to see if it gets corrected as I'm not the only one that is effected.

Can you please create a bug report on this issue.

Very good. I submitted the bug report.

Thank you for your assistance.

@mdd12 Can you share the link to the bug?

Number 1860367


There was just an update released for the 390 nVidia driver.

You may want to update and see if the issue is resolved for you.

Thank you franksmcb for the update.

Good and bad news for me.

The good is I took an older drive with the 5.0 kernel and updated it. All worked well. This is good as I volunteer for a "not for profit" organization and had installed UM on the PC they use which has almost identical specs as the machine I have. So I can just update it without worry.

The bad is the drive that was on my backup machine had broken dependencies and wouldn't update. I tried the suggestions that apt gave me (fix broken something, apt install -f), but it didn't help. I'm sure there is a way through the command line but the knowledge level is beyond me. So I did a fresh install. As I was using it as a back up machine, not a big deal except for setting it up the way I like it. Funny how all those little tweaks through the years add up.

Thanks again.

Hi. I had issues in the past with resolution on monitors and I solved it by setting vertical and horizontal refresh rate into a config file:

Maybe it helps. It works also on mate 18.04

I faced the same issue after updating in Ubuntu 20.04

You can try deleting the newly installed kernel files in the boot folder and then updating the grub config, it worked for me. Even I faced the same issue after updating via the software updater.
Follow this article: https://debugger-init.blogspot.com/2021/01/solution-ubuntu-2004-display-became-too.html