18.04 Caja Connect to Server not working on Windows shares

Raspberry Pi4b
Ubuntu Server 18.04 with Ubuntu Mate desktop

I'm trying to get a bookmark to work on Caja so that my Python scripts can save log files to the server. I can manually mount the share using the following command:

sudo mount -v -t cifs //Server1/tester /mnt/temp_test -o [email protected],password=tester

Technically speaking the Windows server is Server1 and tester is a shared drive on it.

Caja "Files->Connect to Sever" using a Windows share type will either fail in the Folder selection or on the user details. I've tried numerous variations in the Caja Server/Share inputs with no success. Here are my troubleshooting notes so far:

  1. The mount command will not work with a "-t nfs" configuration.
  2. Caja share is installed: "sudo apt-get install caja-share".
  3. Tried apt-get --fix-missing and --fix-broken with no success.

I'm guessing that I'm missing something that Caja needs(maybe samba?) because I'm built from jamesachambers unofficial Raspberry Pi4 image. I've not installed Samba as the mount command works when selecting a "-t cfs" type drive.

Any help is appreciated.

  1. Yes, you need to install samba to work with windows shares.

  2. I never could make Files > Connect to Sever work. Always ended up typing the IP address in the address bar and then bookmarking after connected. One of Caja's many fallacies I'm afraid.

  3. Allow Caja to save your server credentials if your going to save log files to the server unattended.

Thanks Steven.

I was trying to avoid loading Samba as most installation instructions are for setting up a Samba server which is not what I'm after.

  1. Installed samba with "sudo apt install samba".
  2. After reboot found that both smbd and nmbd were running(rather not have these running.)
  3. Address bar "network://192.xxx.xxx.xx/tester" fails with Unable to mount.
  4. Address bar "smb://192.xxx.xxx.xx/tester" requests a username/password. After entering username/password/save password checkbox and connect, I get another request for a username/password(over and over.)

So it seems your address bar method is talking to the server but maybe my syntax in the address bar is off?

Seems the address bar needs to be "smb://Server1.domain.org/tester".
After entering the password and bookmarking it in Caja I'm wondering where Python sees this? It is not shown in the /mnt directory and can I get it to auto mount after bootup?


Glad you got connected @lynnejohn.

Have you considered https://wiki.ubuntu.com/MountWindowsSharesPermanently?

Hey Stephen,
Funny you mention that as I ended up using autofs. I was trying to go with Caja simply because
of the password security. I had seen your link but I was not familiar with getting the credentials
file set up correctly. Finally decided I needed a better approach than Caja and went here to get autofs running:


I like autofs but wish the password setup was a little better. Maybe having some kind of keychain interface.
Thanks for the feedback.

1 Like