18.04 does reboot but can't log-in

Just upgraded to 18.04 hours ago. I did work with it for 2-3 hours, even with some issues that could be looked at later.


I shut-down and went for a bite. When back I re-booted; then I got the UM logo and the dots. Then I get a grey screen with the little cursor on the top left, then black screen and the mouse arrow appears for a sec. Then black and back to the the little cursor on the top left then the mouse arrow, again. I let it do that for about 5 minutes. non-stop. I can’t get to the log-in screen.
Seems to search for something missing. If you know or have a solution, please tell me - this way I won’t have the whole night trying to wake it up…
Full access to the drive data if booting from a flashdrive. So problem is really to repair the log-in; but how ?
LIghtDM issue ? If so, don<t know how to solve it.

After stobburn persistence I was finally able to pass through the log-in, using TTY (Ctlr-alt-F1) and typing StartX. Now I am on 18.04… but no menu, no pannel, no nothing except fanthom desktop icons. I was able to activate Thunderbird (no top menu) and clicked a link to activate Firefox and lead me here. Unless you know how to revive the rest, I’ll try reboot
Ctrl+Alt+T: nothing. no terminal
If I need to re-install something; how can I do it with no menu, no panel, no terminal ?
How to reinstall desktop in that context ?

Hi @Watford,

try running “dpkg” from the recovery menu (network cable connection required):

Ubuntu Mate Update Guide :smiley:

Thanks for your reply. Did try all that. No result.

Hi Watford,

if you have separate root and home partitions, you can follow this guide:


I tried the reinstall option using the USB. Getting different error messages each time I tried; inclusive one saying that sda1 and sdc1 have the same EFI…(!)

Hi Watford,

sorry for the late reply, I’ve been busy with other things/projects.

Use Gparted to delete one of the EFI partitions (the one on sdc1, you only need the one!. :smiley:

This might help?, there is a section covering UEFI at the bottom!:

Thanks for your dedication
I tried all that. But see what I get from the computer

I tried boot repair: no result
And can't access or modify Bios anymore, as stated before.
I'm stuck


Dear Wolfman

New computer here. An HP laptop.
Fresh install of 18.04 LTS on side USB connected SSD.
Keeping it separate from Win10 present on the main board.
Booting UM anyways.
May make it dual boot after a while.

So I solved the whole thing the ‘hard’ way.



1 Like

have you ran a SMART check on your boot drive?

I may be wrong by Smart check is useful to see if the HD is dying… or is end of life.
The basic problem is/was with the Bios being locked for an unknown reason.
The Win10 updates on that drive behave quite weird since April; but I didn’t care since using UM from separate drive on a daily basis.
I’ll try ‘revive’ that computer over spare time.


Hi Watford,

if push comes to shove and you have separate root and home partitions, you can always do a clean install keeping your home intact here:

I have pasted this again for future reference for anyone else reading this thread!. :smiley:

I’ve ‘revived’ the Acer pc with a windows recovery. So basic system.
Tried install UM dual boot. It installs fine. But can’t boot since boot order can’t be altered - it’s frozen. Editbootmgr from the flash drive doesn’t alter it either.
Sits on the shelf 'til a find a way.


1 Like