[18.10] Both machines boots on initramfs after latest rounds of updates?


#1

Hello,

I have 2 laptops, both running Ubuntu MATE 18.10. Yesterday there were a bunch of updates that I applied on both machines.

This morning both fail to boot exhibiting the same error: they dump me into an initramfs rescue shell.

Both laptops I believe were installed using LVM, one of them as luks installed on boot and the other does not. The one with luks on, states a LVM error while the one other just stalls at the MATE boot splash screen with the 5 dots under it before dumping into rescue shell.

dmesg gives no informations nor error on either systems.

Anybody else having this very frustrating “miraculous” problem?

Thanks in advance,

EDIT: I am fairly unskilled when it comes to this kind of situation however baselining from https://wiki.debian.org/InitramfsDebug I can add that:

  1. I see all of the /dev/sda* on both machines;
  2. dmesg has no obvious errors on either machines;
  3. /proc/cmdline seems standard (BOOT_IMAGE=/vmlinuz-4.18.0-13-generic root=/dev/mapper/ubuntu–mate–vg-root ro quiet splash)(luks one) and ((BOOT_IMAGE=/vmlinuz-4.18.0-13-generic root=/dev/mapper/ubuntu–mate–vg-root ro quiet splash vt.handoff=1)(non-luks’ed one)
  4. “blkid -o value -s TYPE /dev/sdaX” returns all valid FS types (1=vfat, 2=ext4, 3=crypto_LUKS) and (1=ext4 2=LVM2_member)(non-luks’ed one)
  5. /proc/modules shows 35 Live modules with no errors (luks) and 13 for the non-luks’ed one;
  6. /var/log is empty/unexistant.

#2

The problem is/was with vmlinuz-4.18.0-13-generic.

Booted using 4.18.0.1-generic and it worked fine again on both.