19.10 freezing when Firefox hits 100% CPU

Not sure why this is happening however upgraded to 19.10 and all seemed fine.

However, when trying to work with PDF files using Atril, LibreOffice Draw and even Sejda Desktop, Mate freezes and forces me to hard reboot. Cannot get to terminal or even use keystrokes or my force quit shortcut in my panel.

Anyone experiencing this and if so, any solutions welcome.

Mate 1.22.2, Kernel Linux 5.3.0-19-generic x86_64

Thanks in advance as always for the help!

Can you boot into an older kernel and see if this issue exists?

Still a bit of a newbie so not sure really how to do that....willing to try tho!

You will need to reboot the system. When your system restarts please hold down the Shift key and this will book you into the Grub menu.

Use the arrow keys to choose Advanced options for Ubuntu and select Enter
The next screen should list available kernels. Since this is 19.10 you should see a listing that includes:

Ubuntu, with Linux 5.3.0-18-generic

Select that one and press Enter and that should boot you into an older kernel.

These images below should give you a visual idea, ignore the versions:


Once you have booted into the system confirm the kernel level. An easy way is to open up the terminal and type: uname -a

Now try and open the pdf's and see what your results are and let us know.

Appreciate the help and will try next few days. I've been looking into it as well and system is maxing out and it appears Firefox is hogging resources too.


Sorry for the late reply.

It appears that it is NOT a PDF issue but rather that Firefox is really using up all my CPU.

Here are my steps to test:

  • Booted normally.
  • Opened system monitor
  • Opened FF ONLY...5 tabs total from previous session.
  • CPU went to 98.5%
    Waited for CPU to lower down which it did now at 31%.

Next test was to boot up and try same steps EXCEPT opened Google Chrome in front of FF. Let my tabs open in Chrome first. All were loaded. CPU usage only went to 60%. Once FF began to load, system monitor hit 100% and froze.

Waited for 3-5 minutes and system never worked. Forced to do hard reboot as I could not use my Force Quit.

Is this a function of the new FF using too much resources? I tend to use 2 browsers at the same time and like FF although if it continues to do this, may move over to Brave as my 2nd browser.

Looking for any advice on this and sorry that it appeared to be a PDF issue. It is definitely NOT that as I can work fine on PDF files on my other computer as well as this one if FF is closed.

Hmm.. this is strange, it works on Manjaro :slight_smile: try reinstalling Firefox and see if the issue persists. If it does, create a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles) and try there :slight_smile:

Will definitely uninstall and reinstall. Thanks for your help


Nice, and no problem

Uninstalled and reinstalled.

FF version 70.0. Eats up lots of resources when loading 4 tabs then settles down.

Have not yet been able to duplicate the freezing issue but will advise over the next few days of use.

Again, thank you for your help.

No problem :slight_smile: Hopefully you can get everything working, if not, report back here!

Set up new profile and FF working and actually seemed quicker. CPU usage still high but workable so began eliminating other variables.

Opened FF and Chrome at same time, 4 tabs in FF, 5 in Chrome. Sluggish and eventually froze. Waited for over 5 minutes and system came back. Duplicated it again and did hard reboot.
Opened FF and Brave. Sluggish but worked OK. 3 tabs in Brave, same 4 in FF. Sluggish but did not freeze.
Closed everything down and opened up LibreOffice and began to work on files there. PDF document that I opened in Draw. Tried to insert an image, system froze. NO BROWSERS WERE OPEN.
Waited patiently and eventually had to do hard reboot. Attempted same procedure with a different file, same result.
I have uninstalled LO and will reboot after reinstalling.

I have noticed that my CPU seems to be maxxing out but when I look at the system monitor and processes, nothing shows up there using a lot of the resources but it almost seems that something is running in the background? Could it be a driver issue? I looked through Other Drivers under Software and I am using the Xorg driver for graphics as the NVIDIA one was really slowing the system down in 19.04.

Will continue to work through this but any assistance is always welcome.

Thanks in advance.

That's strange. You might want to try changing your driver. Also, can you use a live USB and see if the same issue persists?
Sorry, I dont use Ubuntu (Manjaro advocate here) but I try to help Ubuntu users....

Will try the USB method as opposed to changing drivers. Easier for a newbie like me!

I have now been able to run 3 open browsers (in different workspaces) Brave, FF and Chrome and CPU usage is around 47%. As soon as I open a document (ANY PDF) in LO, the system freezes whether or not I have any browsers open.

Almost appears that trying to open a PDF in LO Draw is the issue. Still looking for a program that can handle annotation and signatures for PDF so a suggestion there might assist me in this mystery.

If I open LO and work in Writer, Calc or Impress - no issues!

Will update on USB in next few days.

Thanks again for the assistance....VERY much appreciated.

1 Like

Great, and no problem! The USB isn't a method to fix it, it's a way to check if the issue is with your hardware or with your current installation of Ubuntu MATE.

Understand and familiar with that process.

It definitely appears to be something associated with LO. All aspects of the system working fine and resources down to normal till we open LO. Then system maxes out and slows right down.


I have 6GB of RAM and I don't know if it's Firefox problem or not but for me this problem occurred about 4 times, first when I left my laptop locked for half hour and then I found it frozen and impossible to use, second when I used some pinta app which I suspected mono is the culprit, but the other two cases I have no idea what caused the problem, it's strange, but I think there is some issue hidden somewhere, I will try to force my machine for hard work to reproduce the freezing.

Then why don't you reinstall LO? If that dosen't fix anything, please try downloading the AppImage from the site and see if that works. Also, try enabling/disabling Hardware Acceleration in LO Options>Advanced IIRC

I actually did uninstall and reinstall LO from the software boutique.

No difference at all. Did not download the image (assume that is what you are referring to with AppImage?

I will look at your other suggestions though as soon as I can.

Thanks for the help!

I mean the AppImage from their website, the one click executable which is one file... Try uninstalling normal LO and do that. Also, rename the thread to something related to LO if you can