[19.10] Issues with screensaver (Immediate energy saving mode)


Before I start, I want to state that this system I am having a screensaver problem with originally ran 19.04 and was upgraded to 19.10. Also running latest everything at the time of writing this.

So, I have 2 instances of the screensaver entry under the MATE Menu. I understand that one of them was installed when deploying some screensaver*extra package.

The problem I have now is that even if both(yes, is stupid but I surely had to try it(And BOTH screensavers DID kicked in for a while too :expressionless:)) daemons are up that no screensaver kicks in and both of my screens will go immediately blank/energy saver.

Now I would also like to point out the fact that I am using dual 19:10 screens which are both rotated 90 degrees to the left (hence both in dual portrait (or both in reverse portrait, but it wouldn't matter at this point)).

Now, I clearly remember the screensaver working before. According to me, the 3 things that changed were:

#1: Constantly applied latest patches;

#2: Last time my screensaver worked was when I only had one widescreen monitor plugged in and NOT rotated. I did added a 2nd monitor (same SKU) however...

#3: So I went from 1x widescreen monitor running in regular horizontal position up to 2 widescreen monitors both running in "non-regular" vertical position.

I am pretty positive my issue is that I, again, did something that hadn't been intended by the Almighty Linux community hence I am once again into unknown territories here.

Do anybody use a dual head setup(2 monitors) with both monitors in a portrait position? If so, do you experience any of that weird stuff that I do?

I wish I would had kept my invoice for this warranty thing people just keep talking about but I did not hence me now injecting this into this great project.


Well, I thought this was working fine on my laptop running a full reinstall but it seems that there is something fighting for energy saving settings.

Now that I am thinking about it, I mostly/only use that laptop to watch streamed TV. I remember SMPlayer (Or was it VLC?) taking over/modifying energy settings (IE: Skip them when screen is open).

Could there be such thing w/ mpv? I have checked around it and there isn't much one can do so I doubt so but just wanted to point that out now.

Well I finally rebooted using the latest kernel hence am now running this (after a long 2 weeks overdue reboot):

Linux T-2031 5.3.0-26-generic #28-Ubuntu SMP Wed Dec 18 05:37:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

And my screensaver has kicked back in. Now I do not believe this issue happened from patches but more rather because I am using 2x widescreens in portrait mode.

As far as the laptop goes, even tho I have rebooted it a long time ago and am still mostly/only using it for mpv the screensaver still hasn't showed back up.

Also, I live in a strange world talking to myself.

Cheers :wink:

Maybe today is a great day because I also have new infos concerning my "dead screensaver" on my laptop.

First, I need to mention this laptop as a built-in screen of 15.4" and also uses a 65" ULED TV as 2nd screen. Both screens are configured as mirrors of one another. For the idea is to have the laptop lid closed at all time while the TV is used as primarily when system get invoked.

And I think this is the problem: that screensaver now having a problem with that.

What makes me believe this is because I have just opened the lid of the laptop with the TV off and I saw the screensaver active on it. When I opened up the TV and also left the 15.4" on, the screensaver doesn't show up and ultimately both screens end up in energy saving more.

To add more, I remember very well (during last year at least) that it, the screensaver, always displayed correctly on both screens.

Could there was a change done into power saver/screensaver/video driver/multiple screens in the last blue moon that could be responsible for all of those conditions I am getting? Am kinda good at finding "those" conditions...


Another point to (maybe) consider in this thread is the now the fact that not only doesn't the screensaver kicks in within 10 minutes but rather the screen goes blank within ~120 seconds now, that my audio control (Not the one at the top hand right side bar but rather the one from MATE menu -> Sound -> Output volume at the top) is being automatically resetted to 100% when this happens.

So in other words, when playing some .mkv files it happens that sometimes even if the audio control at the top hand right side is set to 100% that the audio is still yet not fully audiable. My solution is to also cram the "Output volume" from "Sound" to 100% so it then audio really gets pushed out of the HDMI plug.

Of course, if we pause the video for 2 minutes the TV will fall into sleep mode and then Linux looses it's audio sensing configs, It seems...


I haven't seen that problem as you describe it, but I have seen something similar. I have more than one audio device and under certain conditions the audio settings forget which device I had set. Once I select it again, everything works again.

Yes, resetting settings fixes everything.

If anything I can add to make my case more unique is the fact that I require both audio device: being the HDMI for when we play from the TV AND the onboard 1/8" regular audio jack (which is used with a headset).

Both are/were used randomly however we don't need to be doing that in order for this problem to arise.

Thanks for your addition to this thread @goinglinux

So 4 days ago my screensaver worked again on my main box (The one w/ 2 screens in portrait).

Except that didn't lasted long. Indeed, yesterday, my screens both went into energy saver "immediately" (Just like the TV plugged into my laptop does) and once again skipped the screensaver.

Only thing that changed from my perspective was applying the following:

Start-Date: 2020-01-16 10:08:07
Commandline: aptdaemon role='role-commit-packages' sender=':1.1646'
Upgrade: gir1.2-snapd-1:amd64 (1.49-0ubuntu1, 1.49-0ubuntu1.19.10.0), libsnapd-glib1:amd64 (1.49-0ubuntu1, 1.49-0ubuntu1.19.10.0)
End-Date: 2020-01-16 10:08:08

Start-Date: 2020-01-16 20:26:26
Commandline: apt full-upgrade -y
Requested-By: dls (1000)
Upgrade: fdisk:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), uuid-runtime:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libfdisk1:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libpulsedsp:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), pulseaudio:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), libmount1:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), util-linux:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), mount:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libblkid1:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libpulse0:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), libpulse0:i386 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), libpulse-mainloop-glib0:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), libuuid1:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libuuid1:i386 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), libsmartcols1:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), rfkill:amd64 (2.34-0.1ubuntu2, 2.34-0.1ubuntu2.1), bsdutils:amd64 (1:2.34-0.1ubuntu2, 1:2.34-0.1ubuntu2.1), pulseaudio-module-bluetooth:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1), pulseaudio-utils:amd64 (1:13.0-1ubuntu1, 1:13.0-1ubuntu1.1)
End-Date: 2020-01-16 20:26:37

Fear not, I will be back.

Another update concerning my laptop hooked up on the TV.

I again opened up the lid somewhen today and saw the screensaver on both screens.

Only thing that changed from my perspective is/was:

Start-Date: 2020-01-23 20:31:00
Commandline: aptdaemon role='role-commit-packages' sender=':1.4122'
Upgrade: libcom-err2:amd64 (1.45.3-4ubuntu2, 1.45.3-4ubuntu2.1), libwbclient0:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), python3-aptdaemon.gtk3widgets:amd64 (1.1.1+bzr982-0ubuntu28, 1.1.1+bzr982-0ubuntu28.1), e2fsprogs:amd64 (1.45.3-4ubuntu2, 1.45.3-4ubuntu2.1), sysstat:amd64 (12.0.6-1, 12.0.6-1ubuntu0.1), python-apt-common:amd64 (1.9.0ubuntu1, 1.9.0ubuntu1.3), libss2:amd64 (1.45.3-4ubuntu2, 1.45.3-4ubuntu2.1), samba-libs:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), libext2fs2:amd64 (1.45.3-4ubuntu2, 1.45.3-4ubuntu2.1), python3-samba:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), samba-common:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), chromium-codecs-ffmpeg-extra:amd64 (77.0.3865.120-0ubuntu1.19.10.1, 79.0.3945.79-0ubuntu0.19.10.2), libsmbclient:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), smbclient:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), samba-common-bin:amd64 (2:4.10.7+dfsg-0ubuntu2.3, 2:4.10.7+dfsg-0ubuntu2.4), aptdaemon-data:amd64 (1.1.1+bzr982-0ubuntu28, 1.1.1+bzr982-0ubuntu28.1), python3-aptdaemon:amd64 (1.1.1+bzr982-0ubuntu28, 1.1.1+bzr982-0ubuntu28.1), aptdaemon:amd64 (1.1.1+bzr982-0ubuntu28, 1.1.1+bzr982-0ubuntu28.1), logsave:amd64 (1.45.3-4ubuntu2, 1.45.3-4ubuntu2.1), python3-apt:amd64 (1.9.0ubuntu1, 1.9.0ubuntu1.3)
End-Date: 2020-01-23 20:31:46

uptime on this system is now 15 days and even though MOST of the time I am having an issue with the screensaver, every now and NOT so then, it works.