[20.04 Mate] Add Hidden Extras to Top Panel

This new clock is default clock starting 19.10 cycle. Any particular reason to remove it and use
an old clock applet?

I didn't find any way to have it look like the old clock I'm using in addition, at the middle of the top panel. Specifically DayOfWeek, Month, Day, and Seconds. Here in COVID lockdown, DayOfWeek is surprisingly helpful. :crazy_face:
Seconds I've used occasionally for years, even on my (ugh) Mac. Life is short - must use every second remaining. :wink:
Clock1.24.0-quoteOld

1 Like

There are a couple of ways of getting the clock with day, date, etc. The first does not require any additional software but the second is much simpler.

Method 1: Replace the applet with the "old" clock and the "old" indicator.

  1. Right-click on the "Indicator Applet Complete" identified in @ironfoot's illustration.
  2. Uncheck Lock to Panel.
  3. Right-click again and select Remove from Panel.
  4. Right-click on a blank space on the panel and select Add to Panel.
  5. Select Clock from the list and click Add.
  6. Right-click on the clock applet and select Move.
  7. Drag it to the far right end of the panel and press the Enter key to stop moving it.
  8. Right-click on a blank space on the panel and select Add to Panel.
  9. Select Indicator Applet from the list and click Add. (Note: Do not select Indicator Applet Complete.)
  10. Right-click on the left end of the indicator applet and select Move.
  11. Drag it right so that it is just to the left of the clock and press the Enter key to stop moving it.

Once you have both applets in place you can right-click each in turn to lock them so you don't move them accidentally.

Method 2: Modify the existing clock.
This method requires that you install dconf Editor and change the clock's properties ever so slightly.

  1. If you have install "Software" or the "Synaptic" package manager, you can search for dconf Editor and install it graphically. Otherwise open a terminal and type: sudo apt install dconf-editor.
  2. Open dconf Editor from the menu. You will get a scary warning asking you to promise to be careful.
  3. At the top of the application window (in the title bar click the magnifier icon) search for /com/canonical/indicator/datetime/.
  4. Select the two switches "show-date" and/or "show-day" as you wish.
  5. Close dconf Editor.
10 Likes

... and don't forget "show-seconds" toggle as well.

However, this will not give you exactly the same look you had in your old clock applet (comma-separated date and time). If you want that, you have to construct custom date-time format.

This terminal command will tell your clock use custom format:
gsettings set com.canonical.indicator.datetime time-format 'custom'

This provides custom format string:
gsettings set com.canonical.indicator.datetime custom-time-format '%a %b %d, %X'

You may set them via dconf-editor as well.

3 Likes

Cool! :slightly_smiling_face:
I started with Method 1 and immediately messed up when I removed the Ind.Applet. The keyboard indicator applet zapped over to the far-right and I couldn't move or remove it. Futzed with dconf Editor a while with no success but a tiny bit more idea of what's going on. Then finally got rid of it. After that I just started over using the great info shared here so far, to build a less cluttered and rearranged Panel using only the old Add To Panel applets. Later I may drag in some new stuff, put it in the Plank, or just remain content with the sparse simplicity of the old stuff.

Now that it's working well, I'm smiling at how much quicker and easier it probably would've been to use Method 2. But where's the fun in that?! :smirk:

Anyway, thank you for the quick and detailed reply. I'm getting more excited about 20.04 Mate by the minute. :smiley:

Thanks. :slightly_smiling_face:
Had I wisely gone with Method 2 this would've been quite helpful. I'm appreciating how quick the helpful replies are here, and hoping it's not just because everyone else is stuck at home like me. If I ever do go back to the new clock, your config tips will be a great help.

Now on to my next distraction... :wink:

1 Like

Thanks for that @goinglinux ... I can finally have full date & clock again :+1: Screenshot at 2020-05-21 11-06-37
Trough looking at it now, it doesn't show it in correct way for me. Looks like it doesn't take into consideration system preferences. Is it possible to change day and month so it could be like for example Thu 21 May?

BTW it's also possible to do 1 click install Dconf Editor in Welcome - Software Boutique under System Tools.

Hi @ele,

for some reason, indicator-datetime does not fully respect your system settings and indeed displays date in [month] [day] format for different locales. I am afraid, the only way to change this is to construct custom date and time format.
In the same dconf section find time-format key and set it to 'custom'.
After that, find custom-time-format key and set it to, for example, '%a %d %b, %H:%M:%S'.
You may learn other format codes from date --help command in your terminal and construct format string suiting your needs.

Cheers

Nope. Not the case. I really wish people would phrase this as Installing dconf-editor to modify this is the recommended option, but if you'd rather do it through the terminal perform these commands:

gsettings get com.canonical.indicator.datetime show-time false
gsettings get com.canonical.indicator.datetime show-day false

No, I do not care how user-unfriendly this sounds. Replying toward me with that is effectively replying to nobody. No additional software is necessary, and the bonus is you can provide this as a script for people to use post-install in the future.

Thank you @ironfoot for providing a third method, via the command line! And like "Method 1" it does not require additional software. Thank you, too, for explaining what each command does rather than encouraging users to blindly copy and paste commands, risking victimization by malicious actors!

For anyone reading, in the future, the reply from @tiox (Brandon Bachman) and thinking that the "Method 2" I outlined above is incorrect, it is not. (The method works for Ubuntu MATE. I tested it before posting. The name of the application to be installed is displayed in the menus as "dconf Editor" and the name of the installed package is "dconf-editor".)

I think that @tiox is attempting to provide a fourth method of displaying additional components in the indicator. (Apparently, in his haste to express his righteous indignation, he forgot to be accurate.)

Unfortunately, simply copying and pasting those commands will not achieve the desired result. The command "gsettings get" does not change a setting. You want to use "gsettings set" instead. Here is what will actually work, along with an explanation of each command:

This terminal command will tell your system to show the day of the week:
gsettings set com.canonical.indicator.datetime show-day true

This one shows the month and date:
gsettings set com.canonical.indicator.datetime show-date true

This one shows the seconds as part of the time:
gsettings set com.canonical.indicator.datetime show-seconds true

Well said, Brandon.

3 Likes

Apologies. In my fervor and lividness I forgot to change get to set. Thank you for aiding my cause.

Apologies if I was seeming indignant. I am just tired of people posting incomplete solutions, and not providing what would be faster for people to just copy and paste. While I do completely understand where @ironfoot and you are coming from with malicious actors and such, generally a helpful answer will also be a truthful answer. Any cause for maliciousness is usually snuffed along with its avatars pretty quickly around here.

Thank you @tiox! I agree that using the command line is faster. Not always as clear to new users, though. That's why I prefer to explain using point-and-click solutions where they will work and are not 5,000 steps long. :grin:

1 Like

gsettings set com.canonical.indicator.datetime custom-time-format '%a %d %b, %H:%M'
Unable to change the date format even by taping the command in the shell... A bug ?

Hi @monsieurzik,

this will only work, if time-format key is set to 'custom'.

1 Like

Already done ... Tried several times

What is the output from these commands?
gsettings get com.canonical.indicator.datetime time-format
gsettings get com.canonical.indicator.datetime custom-time-format

2 Likes

It's OK now. With the commands you ask for, I have understand that i didn't set "time format" on "custom".
It's working like a charm now. Thanks again.

2 Likes

Thank you. I've trying to figure out how to do this. Guess it pays to look around this forum. Again, thanks.

VLC recently hosed up my Panel clock, so this thread was super helpful AGAIN! :smiley:
I'd already fixed the VLC issue by turning off the panel icons in VLC Prefs, but the clock had reverted to default settings when I reset the Panel. It's great having day/month/date/h/m/s back thanks to the helpers here, so this is by way of another big Thank You.
Also, to extol the virtues of dconf Editor that's been so helpful for other tweaks, and for carefully getting a better idea of what's going on "behind the scenes" in Ubuntu. So thank you also for introducing those of us not already aware of it, to that app!

Man OH man, MY oh MY -- does this have 'feature request' written all over it.

:wink: