20.04 - Screen Tearing

Hello,

I read in the changelog marco is the only and default window manager in 20.04 and:

" screen tearing is now a thing of the past"
"Marco is free from screen tearing"

No, it's definitely not! I've massive screen tearing everywhere! Videos, during firefox smooth scrolling etc.
I've used compiz to solve this issue before but now...

My config is: I5 6200U, Intel HD 520

Can u give me any solution?
Thank you!

Does this help? https://askubuntu.com/questions/418398/tear-free-disabled-in-intel-graphics-tearing-in-xubuntu#469653

1 Like

Thank you!
I read somewhere this config file may cause more ram usage and performance impact. Is is true?

Possible, but I think it should not be that big of a deal. Just try it out.

Btw. on my GTX 1050Ti I also had to to force full compositing pipeline in the drivers to get rid of tearing.
I think the release notes are overselling it a bit - maybe on AMD everything is fine, but on Intel and NVidia both not so much...

I have the same problem---I experience screen tearing when I watch Youtube videos, Amazon Prime video, etc. I tried applying the 20-intel.conf thing as suggested in https://askubuntu.com/questions/418398/tear-free-disabled-in-intel-graphics-tearing-in-xubuntu#469653. This fixes the above mentioned problems but it crashes mpv and vlc.

For VLC you can maybe try a different video output mode.

Thank you maximuscore, I tried lecacy video output (xv) for mpv, which is now working. By the way from mpv's manual I learned it has video output "caca". I tried it, and this was hilarious---as it is intended to be---hahaha.

1 Like

Well for my optimus laptop
Screen tearing on nvidia card is still here
options nvidia-drm modeset=1

in /etc/modprobe.d/nvidia-drm-nomodeset.conf doesn't fix screen tearing.
Something get wrong with 20.04
On 18.04.4 i don't have this issue...

I used compiz to negate screen tearing. Macro had too much screen tearing in vlc/mpv. Now it's smooth as butter. I'm using default modestting driver for my intel iGPU.

1 Like

Fix screen tearing for nvidia GPU:

  1. Use the NVIDIA proprietary driver (version maybe affect 4.)
  2. Select NVIDIA X Server Settings from control center
  3. Select the X Server Display Configuration
  4. Click on the advanced button and check Force Composition Pipeline
  5. Click on the button Save to X configuration file to set it at startup.

Fix for Firefox:

  1. about:config
  2. Set layers.acceleration.force-enabled to true
4 Likes

So I have an odd issue with this. It does, in fact, get rid of the screen tearing.

But now Cura segfaults every time I go to launch it.

And Slic3r apparently does the same thing. It's less verbose, so I don't actually know if it's a segfault, but it launches, freezes, and quits.

Lenovo Thinkpad E550.
Release 20.04 LTS (Focal Fossa) 64-bit
Kernel Linux 5.4.0-31-generic x86_64
MATE 1.24.0
15.4 GiB RAM
Intel® Core™ i5-5200U CPU @ 2.20GHz × 4
Mesa Intel® HD Graphics 5500 (BDW GT2)

Thanks a lot. That fixed my tearing issue.

Worked for me to get rid of screen tearing in firefox (e.g. youtube)! Thank you very much.

Accepted solution here causes much more issues in applications such as celluloid, mpv and brave browser. This seems to break brave completely making it impossible to minimize or resize.

I installed compton and old Marco(Compton) option showed after that. It seems to fix all screen tearing issues for me (I have an Intel iGPU). In an another machine option didnt show up in mate-tweak-tool so I used Marco(No compositing) option and added compton to startup manually.