A few issues to report with 16.04 LTS

16-04-xenial
bugs

#1

Okay, so I thought I might report a few issues that are creeping in of late in UM. I am currently using a fresh install (installed a couple of weeks ago from the latest download) of UM 16.04 64 bit.

The issues are:

Every login, something on Mate panel crashes. Usually the power manager.

The wifi keeps disconnecting during a session and demanding I re-enter my wifi password to re-connect. Since I don’t use wifi, I simply tell my network manager to not use wifi. But, when I next log in, wifi has been both reinstated and is also regularly disconnecting, causing me to have to re-connect and/or disconnect wifi during every session.

There is a significant problem with usb connections. This takes the form of hanging every now and then during login or during shutdown where it comes up with console messages about not being able to set “frequencies”. This is causing me to have to cold -reboot by pressing and holding the power button. This problem seems to be extending into the actual sessions as well whereby my usb webcam is not now being picked up.

I have temporarily installed an Arch distro to see if it is a wider Linux or specifically Debian issue. It is not happening with the Arch distro. So, my next step is to install a vanilla Debian to see if it is a Debian or Ubuntu Issue.

Anyone else noticing similar issues?


#2

[i’m not seeing what kind of system you’re using?]

Lots of times i have to reboot 2, 3, 4 times, until systemd stops goofing around and makes it all the way to the login screen. The login screen always blinks after its first display, no big deal, but an oddity.

I was having problems with systemd not completing some (bind) mounts, but that seems to have passed in the rev-75 kernel, knock on wood.

Other than that it’s great. I’ve been thinking maybe i should install the latest and greatest but the 17.04 iso seemed to be missing some drivers last time i tried it; 16.04 seems to be pretty decent and i can do work with it. Other than systemd issues, the most annoying thing i have to deal with (xps13-9343) is that sometimes when at the login screen, after suspend, it has turned off the keyboard backlighting and i have to poke around in the dark to find it; if that’s as bad as i have to deal with, i’m in fat city.

Once i’m logged in, everything is pretty good. The problems i see are coming from upstream as far as i can tell but they’re also getting resolved, presumably from upstream, but i dunno for sure who’s fixing what.


#3

Hi steve and thanks for those reports.

This is happening sometimes, few times actually, but not sure from which applet.

In 16.04 versions this seems to be a current “bug” - Here, i haven’t noticed that wifi stopped during session, but i have to restart it from suspend
UM woks mostly like a charm on my desktop, issue are mostly encountered on laptop - That makes me think about trying Xubuntu +Caja but those aren’t big deal !

Another feedback if you allow me, would be this :


this occured only with Mate, unfortunately

Thanks for your concern Steve
enjoy your day


#4

Hi crankypuss

I do have this issue too sometimes - i wait or try ctrl + alt + supp/backspace then i get the keyboard working again in login screen.

Those are not big deal for people who are invested in Free Software Cause, used to deal with little issues, but for non experimented users who just expect to run computer nicely and ready to work, i guess it could be “repulsive” and for bad reasons …


#5

I seem to be on the lucky scale of having stable and smooth systems under 16.04. :confused:

Just to confirm, are you using MATE 1.12 (pre-installed) or the MATE 1.16 upgrade for Xenial too?


#6

@stevecook172001 Could you please post a inxi -ACDMNSG so that we will have more information.


#7

Hi Lah7. It’s the preinstalled 1.12


#8

Sure, no problem:

System:    Host: server Kernel: 4.4.0-75-lowlatency x86_64 (64 bit) Desktop: MATE 1.12.1
           Distro: Ubuntu 16.04 xenial
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: H81M-PLUS v: Rev X.0x Bios: American Megatrends v: 2104 date: 08/08/2014
CPU:       Dual core Intel Core i3-4160 (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3600 MHz 1: 3576 MHz 2: 3600 MHz 3: 2746 MHz 4: 3600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Bonaire [Radeon R7 200 Series]
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: [email protected]
           GLX Renderer: Gallium 0.4 on AMD BONAIRE (DRM 2.43.0 / 4.4.0-75-lowlatency, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 12.0.6
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
           driver: snd_hda_intel
           Card-3 Logitech Webcam C270 driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.4.0-75-lowlatency
Network:   Card-1: Realtek RTL8192CE PCIe Wireless Network Adapter driver: rtl8192ce
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           Card-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives:    HDD Total Size: 1750.4GB (56.1% used) ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD5000AZLX size: 500.1GB
           ID-3: USB /dev/sdc model: Storage_Device size: 250.1GB

#9

Got no help Steve. That looks solid to me.

I’ve just finished doing an install from the 16.04.2 iso on a laptop and will poke around as time permits. Thanks.


#10

I can confirm this bug. It exits only in Ubuntu MATE 16.04 as far as I can tell. Other Ubuntu 16.04 distros don’t do this. I have tried Lubuntu 16.04, LXLE 16.04 and Bodhi Linux 4 (16.04). Something is triggering wifi during boot in Ubuntu MATE and the setting is not persistent. I changed from Network Manger to wicd and thought that solved it. But I soon discovered the problem was deeper so wicd changed nothing. This might be seen as a minor bug, but made me install MATE on top of LXLE 16.04 instead.

There are also a couple of other bugs with open-source radeon driver and window-managers (AMD 6000- and 7000-series graphics):

Marco (software-compositing) crashes Google Chrome. It happens fast especially when watching Youtube.

Marco (Compton) disables screensaver.

I had big problems with Compiz 0.9, but in Ubuntu MATE 16.04.2 it seems stable.


#11

I don’t remember having any problems with MATE 1.12 either. But I can confirm the system is rock solid with MATE 1.16 on my system. I don’t use Wifi of any kind either.

The mate panel crashing was a common problem on my system very early on when I first installed Ubuntu MATE 16.04. But went away when I switched to Marco Software, instead of Compton.


#12

Marco software compositing leaves a lot of tearing on video for me and I don’t like Compiz as I have always found it to be bloated and buggy


#13

Hallo stevecook172001

Nope, no problems on my Tuxedo (built-for-Linux) desktop (64 bit) or my ancient HP (built-for-Linux) netbook (Intel Atom cpu, 2 GB ram, 32 bit). :slight_smile:

I did recently install 17.04 on an old low-end HP (64 bit) laptop. The wireless card wasn’t supported, still that’s not surprising.

So is it down to your hardware?


#14

Are you on a laptop?

Then you could install TLP and tell it to disable Wi-Fi on boot.

Not a fix but a workaround…


#15

No, it’s not down to my hardware. I have used UM 14.04, then later 16.04, with this machine since I built it around a year ago. This problem has only started to occur following a re-installation (of the latest downloaded version) of 16.04 around a week ago.


#16

No, it’s not a laptop


#17

As far as i can tell, compiz seems to avoid “crash panel” at start up … as someone said, this is maybe due to Compton. As a matter of fact, i like to give the preference to Compton as this happened rarely - but i keep trying Compiz and see what happen …


#18

I tried this a couple of weeks ago and the bug was still there. I tried it again today and now it works… This is great, but also a bit confusing because I never had Marco (software) and Google Chrome working before.


#19

I’ve been pretty lucky (knocking on wood). Hard to say why but I’m inclined to think of one thing: Graphics.

For this entire century I’ve completely avoided ATI and been pretty much nVidia - on purpose. The reason goes back 2 decades with Windows NT drivers at work so I’m likely biased when I’m sure I see more issues with ATI/AMD to this day.

But I already know for everyone swearing by something there’s just as many swearing AT that same something. :slight_smile:

You haven’t mentioned graphics but I know one thing. Even panel applets crashing has been frequent in VMs and OFTEN helped with changing graphics. I know VirtualBox isn’t the best graphics but you’ be surprised what it seems to affect.

And no Wifi here, either.

Just my 2 cents.


#20

It may or may not be the graphics card that is implicated in these issues. But, the fact remains that they were not existent prior to my installation of the latest downloaded version of 16.04 I pulled off the download page about a week ago.

I should say, since my initial post on this thread, the panel crashing and wifi randomly disconnecting seems to have abated somewhat. However, my webcam is still not being picked up at all. It is a pretty basic, bog-standard cheap logitech