Accidentally changed from ubuntu mate to kali-rolling

I was working with katoolin to install some specific kali tools. After installing a few tools i ran an upgrade (sudo apt-get update && sudo apt-get upgrade). Later i received a system error because of broken dependencies so i ran

sudo apt-get --fix-broken install

Now i am running:

Kernel: 4.4.0-31-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Kali kali-rolling kali-rolling

…instead of my original Ubuntu distro.

Even after i edit the grub configuration so that i get the grub menu when the system boots up i don’t have an option for the original Ubuntu…only Kali and Ubuntu EFI

How can i get my Ubuntu Mate back?

Hi @larryb,

sudo apt-get install --no-install-recommends ubuntu-mate-core && sudo apt-get install --no-install-recommends ubuntu-mate-desktop

That should ensure you have all the right software installed. Then log into the MATE session and use MATE Tweak to switch away from, and then back to, the “Ubuntu MATE” interface. Then Enable Indicators from MATE Tweak. How that look now?

Info taken from here provided by @Wimpy:

Another alternative is the following terminal command:

sudo apt-get install mate-desktop-environment-extras

Restart after unning the above command and log in to the Mate desktop at the login window!. :smiley:

1 Like

I have the Mate desktop inteface, but the distribution is still ‘kali-rolling’ rather than ubuntu. Does that matter?

Now i have a bigger problem.
I set up grub so that i get the grub menu when i boot up.
After running:

sudo apt-get install mate-desktop-environment-extras

I rebooted, got the grub menu…but on choosing kali it shows the green ubuntu logo on the screen and then the screen goes black and it just stays that way.

HI Larry,

try booting into recovery mode and running “dpkg” (cable network connection required!) per the update guide and let us know how you get on!:

While in recovery mode, drop to “root” and run the following command to re-install grub! (assuming you have grub-pc on your Kali install?).

sudo apt-get update && sudo apt-get remove grub-pc && sudo apt-get install grub-pc

Restart with Ctrl + Alt Del, DO NOT CLICK ON RESUME!.

When i went into recover mode and ran dpkg the following message came up:

can not upgrade
An upgrade from ‘kali-rolling’ to ‘xenial’ is not supported with this tool

I ran root and tried ping, which returned:

Network is unreachable

So i went back to recovery mode and ran ‘network’, which echoed the following a few times:

‘No such file or directory’

…but back at root the ping worked. So i ran the apt-get commands that you specified.

Those apt-get commands returned many ‘failed to fetch’ and ‘temporary failure resolving’ referencing various… pages.

When i re-booted with ctr+alt+del i chose the kali distribution at the grub menu and it went black again.

I ended up re-installing Ubuntu Mate.
Each time i have to re-install i am learning how to do it quicker.
Now i’m using rsync to make sure that my home configuration files are also backed up.

1 Like

HI Larry,

just out of interest, how did you get Kali and Ubuntu on the same PC?. :smiley:

One way that i did it was through Katoolin.
First, i installed git (sudo apt-get install git)

Then i installed Katoolin by …

  • Downloading it to my machine (sudo git clone
  • Copying the executable to my /usr/bin directory (sudo cp katoolin/ /usr/bin/katoolin)
  • Giving it permission to be an executable (sudo chmod ugo+x /usr/bin/katoolin)

Once it was installed i typed the command to run it IN QUOTES ($ “katoolin”)

From there i was able to install all kinds of Kali goodies.

1 Like

Another way that i did it (i’m a bit of an experimenter) was through the new ‘kali-rolling’ system described here…

1 Like

I now have the same problem after having installed katoolin and am experiencing similar issues; bootloader has changed, missing dependencies for Mate apps and permissions have changed. As if I am running some strange hybrid of kali/mate. Is there any fix without having to reinstall from a disc? I really like my current setup and would rather not have to start over.

Hi @howeuth,

if you have Kali installed, open Synaptic and search for the Kali files, then mark and remove them, at the same time, make sure that you have all the Mate packages installed (search for “mate meta”) and install those and then restart.

If you don’t have Synaptic installed, open a terminal and paste the following command (Ctrl + Alt + t):

sudo apt-get install synaptic

Thank you, @wolfman I got Synaptic installed and downloaded the meta package. I am a noob to linux (though have become a true believer) but am also somewhat of an experimenter like the OP, so navigating synaptic and correctly installing the meta package will take some time. While I am getting a lot of hits in synaptic when I search Kali packages only two are marked as installed.

1 Like

Hi @howeuth,

all you have to do is mark (right click) the Kali packages for complete removal, as far as Mate goes, simply type “mate” in search and look at the packages that are available.

You can also do a clean install and keep your date files intact if you follow this guide!:

A terminal command (Ctrl + Alt + t) for you that will quickly install almost all of the Mate DE:

sudo apt-get install mate-desktop-environment-core mate-desktop-environment-extras ubuntu-mate-welcome

I would also recommend that you get rid of katoolin as that was the same program that caused my issues.
For a good Kali (or Parrot) OS get a USB drive to install it on rather than messing with your whole system…that’s what worked best for me at least.

1 Like

Same here, for me it was showing to boot into Ubuntu but now I did something show booting into kali, I guess I Will just reinstall Ubuntu :sweat_smile: