All USB Disks No Longer Auto Mount

Typically when inserting a USB Disk (thumb drive), it auto mounts and the window of that drive appears. I have one PC where that action suddenly stopped. I can go to Disks and see the USB disk and mount it from there. I am not sure why the default action stopped, but how can I return the default behavior of auto mount.

Open caja, Edit > Preferences > Media ... is Browse media when inserted selected ?

Yes it is. I tried toggling the setting, but that did not work.

And I just tried on a different account on the same PC and the USB mounts as expected.