Any way to change the mate-screensaver slideshow rate?

Hello, the mate-screensaver picture slideshow works great to randomly display my thousands of pics, however each only stays up for a few seconds. Would like to slow that down. But nothing in the GUI options allows that so wondering if there's a prefs file somewhere that I can edit? Searched the Mate forums and poked around the Mate system files a bit but nothing about slideshow rate. Maybe this needs to be a feature request. If so where should that be submitted so developers see it? Thanks for any help on this.

@gigama, I also didn't find the customization that I wanted - applying themes and window control on the screen saver dialogue. I started reading and working on tinkering with the codebase, it would take time due to me looking for a job alongside this.

The configuration was not found but can try to look for it in the codebase. Will revert when I find it, here.

@ksmanu, thanks for following up on my request. Since my actual screensaver changes to a new image every 10 seconds, my best guess would be to edit mate-screensaver/savers/gste-slideshow.c and change the hardcoded "10" wherever the "start_new_load (show, 10)" function is called, ideally to a user defined variable from the personal-slideshow.desktop.in.in file. But looks like a bunch of frame buffering going on so maybe the "#define IMAGE_LOAD_TIMEOUT 10000" is also part of it. Am not a c programmer.

@gigama You are right. Thanks for sharing this.
224 start_new_load (show, IMAGE_LOAD_TIMEOUT);
called by
341 finish_fade (show);

Changing only the #define IMAGE_LOAD_TIMEOUT - This works in screensaver preview.

It's fairly straightforward to compile this code. Install build-essential and also sudo apt install build-dep mate-screensaver. Change the code and follow Installation instructions given in README.

TODO: Adding a configurable parameter variable and having that value populated by mate-screensaver-preferences.

However this didn't work in the actual case, screensaver slideshow didn't run. I will be looking at it later, in a while, maybe a problem with deployment/installing it.