Anybody else having internet connection issues in 15.04

Hi folks. Just checking whether this issue is particular to my set-up or if it is a more general problem.

It relates to my internet connection and the fact it seems to keep locking up/hanging. I have installed 15.04 on both my desktop and laptop. With 14.04, the wireless internet connection was initially flaky on my desktop machine. But, I identified this as an issue with the wireless card and so fixed that by changing to an ethernet connection, On my laptop, on 14.04, I used both ethernet and wireless and both worked perfectly out of the box.

However, since installing 15.04, the internet connection, both wireless and ethernet, on both my laptop and desktop machine, is regularly dropping out. The only solution being to fully disable networking and then immediately re-enable it, At which point, the internet becomes immediately available again. But, only for a few minutes to half an hour before I must repeat the procedure.

I should say, my laptop is an Acer Aspire 5335 and has a built in Qualcomm Atheros AR928X wireless card. Though, I am mainly using my ethernet slot for internet on it at the moment. On my desktop machine, I use the ethernet exclusively. Irrespective, the connection problem on both machines is happening whichever connection medium I use.

Is this happening to anyone else?

I don't have the same laptop (hp pavillion g series AMD A6-3400M APU with Radeon(tm) HD Graphics)

But I have the same atheros wireless interface : AR9285 Wireless Network Adapter.

It works flawlessly on my machine either with ubuntu-mate 15.04 or fedora 21 with mate
(I have an ubuntu-mate on a 64GB USB key).

Here is the info from lshw for that interface:

product: AR9285 Wireless Network Adapter (PCI-Express) [168C:2B]
vendor: Qualcomm Atheros [168C]
bus info: pci@0000:07:00.0
logical name: wlo1
version: 01
serial: d0:df:9a:0a:xx:xx
width: 64 bits
clock: 33MHz
capabilities:
Power Management,
Message Signalled Interrupts,
PCI Express,
bus mastering,
PCI capabilities listing,
ethernet,
Physical interface,
Wireless-LAN
configuration:
broadcast: yes
driver: ath9k
driverversion: 3.19.5-200.fc21.x86_64
firmware: N/A
ip: xxx.xxx.xxx.xxx
latency: 0
link: yes
multicast: yes
wireless: IEEE 802.11bgn
resources:
irq: 17
memory: f0300000-f030ffff

The symptoms you are experimenting seems effectively to be from a bad wifi driver.

Good luck,

            Bernard

Hi Steve,

I did have the same problem initially but after 15.04 was released, the problem solved itself. There were several network package updates while I was using 15.04, one after the other in fact!.

I have since downgraded to UM14.04 and don’t have any problems with networking!. :smiley:

You could try running this terminal command (Ctrl + Alt + t) and see if it helps as it might be a dependency problem?:

sudo apt-get update && sudo apt-get dist-upgrade -f