Autocorrect bug in LibreOffice

There seems to be a problem with autocorrect in LibreOffice in Hirsute/MATE. There is no auto-capitalization of first words in a sentence, and the replacement table is not being implemented.

This exact issue came up in a Fedora 34 prerelease back in February, and eventually resolved itself with a system update. We were never able to figure out what package fixed it, but it wasn't an update to LO. In any case, I have tried older versions of LO that formerly worked fine, and now also show this bug.

So I'm guessing that this is NOT a bug in LO, or at most, it's an interaction between LO and some 'plumbing'. It's some system component that is causing this. I logged in to Hirsute after being away for a couple of weeks, and after updating, this bug was evident. I picked up 200 and something updates, so hard to say what is responsible.

Anyone have any idea what's going on? Release is tomorrow?

1 Like

I can confirm the issue using default English language while running LibreOffice on Ubuntu 21.04 installation live media (tested on MATE, but others may be also affected). Confirmed on 21.04 minimal system with OpenBox as window manager.

I have reported this bug at LaunchPad as .

For now it is marked as duplicate of .

Hope GTK and LibreOffice teams will fix the issue soon.

Thanks for your help, @sgage !

1 Like

I have also been following this in the Ubuntu Forums/Development subforum. Evidently a version of GTK+3.0 that fixes the issue exists in Debian experimental already - hope it percolates down to the repos quickly.

In the meantime, a workaround is as follows. Launch LO from the command line thusly:


Menubar/Toolbar/StatusBar text might seem a bit off from your preferred theme, but the editing window will be fine, and autocorrect will work as ever. Also, for a one-off autocorrect, follow the word with a tab instead of a space and it will work. Then you can backspace and carry on.

I don't think it should be too long for an official fix.