Ayatana Indicator Settings app - most options greyed out and cannot be set

Hi there! I am using the Jammin' Jellyfish release of UM, and the Cupertino desktop (although this issue happens with the other desktops too).

Basically I cannot alter any of the options in the Ayatana Indicator Settings app, and most of them are greyed out. Here is a screenshot of what happens when I first open it: https://i.gyazo.com/2f062a39c0547df31e5e697fc437b6c9.png

As you can see, it lands on the Settings tab - even though the settings tab is greyed out. All of those switches in that tab (e.g. Show full Username on the Panel) have no effect.

You can see all but two of the tabs down the left hand side are greyed out, and so I cannot access any of those tabs to add or remove icons from the panel.

The options in the Notifications tab have no effect. If we visit Keyboard (the other not greyed out), it is completely empty like this: https://i.gyazo.com/a405b3af7101296900fa7b5662095fe0.png

I've tried switching between Indicator Applet Complete and Indicator Applet, but the problem persists. Strangely, those exact same 4 icons are the only icons shown regardless of which of those two applets I choose (I thought Complete was supposed to have more?).

But yes, I have tried the following:

1, Switching the applet on and off, and switching between Indicator Applet and Indicator Applet Complete.
2, The 'Enable this indicator on login' buttons have no effect.
3, Tried the 'Reset all Applets' function.
4, Tried uninstalling and reinstalling the Ayatana Indicator Settings app.

But still, the settings remain greyed out and cannot be changed.

Does anyone know how to fix this issue?

I have the same options for my UM. Some are greyed out but they have options when I click on them ( Session, Date and Time, Sound and Power) and some are greyed out with only option to enable that function (Messages, Bluetooth and Keyboard)

Hi @mistifieddog,

I only see ayatana-indicator-notifications in your top panel. Do you have other indicators installed? What's the output from apt list --installed | grep ayatana command?