Back to Ubuntu MATE 14.04 from 15.04

Ubuntu MATE 15.04 didn’t work for me for some ‘weird’ unknown reasons. I don’t know if it’s the systemd or the Linux kernel itself, but anyhow it didn’t go very well for me. I’m now back to Ubuntu MATE 14.04 LTS, and until now it’s working great.
Here’s the problems I faced while using Ubuntu MATE 15.04; see whether anyone else have encountered it, and/or provide any solution for me, since it cannot be just me.

  • nm-applet wasn’t working as expected. I created WiFi hotspot but it wasn’t working. Also nm-applet disappeared from the panel quite a few times.
  • Dual-booting wasn’t working at all. After a reboot, or a fresh starting of my laptop, whenever I selected Windows from grub2, I got glitch-like screen and then it just stuck there. I reached nowhere! I restarted the system and tried several times in several ways (mostly non-technical) but couldn’t log into Windows. Ubuntu MATE is my primary OS, but I need to log into Windows once in a while for indomitable reasons.

Except these, other things were working okay I guess. I think systemd isn’t yet ready for the prime time, or it may be the Linux kernel that’s creating the problem for me. But if either of them is the sole reason behind my problem, then I assume someone else has also encountered these problems.

Anyway, I’m back to Ubuntu MATE 14.04 and it’s working just fine. Everything is back to normal as they should be. But still the solution for the aforementioned problems would be greatly appreciated.

I dual boot Ubuntu-MATE 15.04 with Windows and I do not experience these issues with grub. It would be interesting to find out why dual booting didn’t work.

I think one problem is solved. I tried to boot into Windows, which is dual-booted with Ubuntu MATE 14.04, and faced the same problem. It wouldn’t boot. Then I discovered that grub was installed in another partition other where UM is installed. So I reinstalled grub in the proper partition and now it works. I think the problem with UM 15.04 was the same.
The other problem still remains. nm-applet related problem. Did anyone else encounter it?

I went back to 14.04 due to having had a few issues with Ubuntu Mate 15.04 and Jack/Rosegarden/Qsynth apps. All of which work fine on 14.04. Though, I should clarify that I have actually used Ubuntu Studio 14.04 with Ubuntu Mate 1.8 over the top. The reason being the very low audio latency built into the fabric of Ubuntu Studio

I’m running UM 15.04 now and have no problems, I have my updates set to daily and install anything on offer!. :smiley: It is working fine for me. :smiley: