Binding keys for changing language used and lag issue with bluetooth headphones

Hi, all!

I do not have any experience with Linux systems, but today I think that I finally have found a distribution that I like. However, I have a few questions about its usability.

  1. Is it possible to bind specific keyboard layout on Alt+1, Alt+2, Alt+3? I’m using 3 languages on my keyboard and I don’t like to cycle them every time.
    I tried to use “gsettings set org.gnome.desktop.input-sources current 0” but for some reason, it’s not working although I see in dconf Editor how values are changing when I’m using bound keys.

  2. I’m using Sound Blaster JAM Bluetooth headphones however when I’m not using them for a couple of minutes (no audio or video are playing) they get turned off in the hardware sound preferences or sound start lagging when I start an audio. I can fix this simply by reconnecting my headphones but I prefer to fix this issue if it’s possible. I also have to manually choose my headphones in the sound preferences output every time after I connected them.

So how I can avoid this lag issue and how I can make linux to choose my headphones as a primary output devise automatically?

Thanks in advance.

P.S. Sorry for such noob questions. If there were already such topics, please just post a link to them.

Looking forward to answer on these ones

I use 2 languages. Have the small icon on top of the screen that I can check to change language - so far so good. But each time I switch window (alt-tab) the language changes back to English by itself. Can this be changed so that what I choose remain same 'til I choose otherwise ? Maybe the answer to cook1987 will answer this one too…?

Have headphone too. Would also like UM to choose my headphones as a primary output devise automatically when plugged in.

You guys are great and finding ways :slight_smile: