Booting, qpaeq not working, wifi & brightness problems

Hi all,

My first post on this forum. So far I’ve been seeking help on the Ubuntu forum. I have installed Ubuntu Mate on my HP Spectre X2 and having some problems;

  • Booting - Mostly it doesn’t boot. Sometimes it boots to a grey screen with no text or menus visible, and sometimes it boots correctly. I don’t know what (code) to post here to show what the problem might be.

  • The audio in this laptop is Beats Audio and under Windows there is an EQ. Without it the speakers sound terrible, so I needed one and followed this guide to install qpaeq: http://www.webupd8.org/2013/03/install-pulseaudio-with-built-in-system.html however, I can’t get it to start. It shows up in sound preferences > output as “FFT bases equalizer…”. I get the errormessage:

[email protected]:~$ qpaeq
Gtk-Message: Failed to load module “gail”
Gtk-Message: Failed to load module “atk-bridge”

even though I just installed them.

  • Brightness control is weird. I installed xbacklight and if I set the brightness to say 20, the screen reverts to 50. The graphics on this laptop is Intel 4200.

  • I don’t know if this is an error or feature; The computer doesn’t automatically connect to wifi network when it starts. I must go to wifi icon, choose the right wifi network, enter password for “the keyring did not get loaded…” and then again choose the right network for it to connect.

Please let me know if there is something I need to post on here for you to understand the errors.

Thanks :smiley:

This sounds like a general Linux problem with this laptop.

I have included a link to someone who has managed to iron out many of the problems you mentioned

http://cesg.tamu.edu/faculty/paul-gratz/personal/linux-on-the-hp-spectre-13-x2/

Hi,

also make sure that you have fully updated your system:

Did you do a disk install and follow this advice?:

Did you fully format the USB stick to FAT32?.