Caja and Ubuntu Mate 18.10 - I am SOOOO having trouble!

So, one of my main gripes about Ubuntu Mate 16.04 and 18.04 is that I have horrible download speed whenever dealing with a USB drive. (20-100k!) I know my hardware is ok because Windows can send a 700M file in about 20 seconds. Ubuntu takes 8-10 hours!

I did find a partial reprieve in that grsync would copy 1G in about 30 minutes but I had to put it in a file folder.

So, in reading about 18.10, it sounded like someone FINALLY fixed this problem that so many people have. So I upgraded to 18.10 and everything looked fine and worked fine UNTIL I tried to put a file on a thumb drive. Then all H-E-double hockey sticks broke loose. Caja locked up the entire system. I couldn’t do anything but move the mouse pointer. So I held the shutoff button for 5 seconds and re-booted.

I could not reboot. I kept getting to a screen that told me there were parsing errors and gave me an (intramfs) (sp?) prompt. If I typed ‘exit’ then it said I needed to fsck manually. I finally got that to work and came up with a couple of thousand errors, all of which I had to say 'Y’es to.

When I could finally get to my home screen, all of my settings were gone. All of my bookmarks in firefox and waterfox were gone. And now, everything keeps crashing. Kmail crashed, Plank crashed, Waterfox, Firefox, Caja, and on and on.

Now how do I go back?!

Ok. I’m sorry for venting. I love ubuntu mate very much and want to thank everyone who donates their time to making something wonderful for others. Good luck and God bless.

So now it crashed AGAIN! I’ve got this little ‘do not enter’ symbol on the taskbar so I clicked on it and got…

E: Problem parsing dependency 21
E: Error occurred while processing kmail (NewVersion2)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

and now waterfox and firefox have lost all of their settings … again.

I don’t even use kmail. I tried to remove and/or purge it but get the same parsing 21 error.

[email protected]:~$ sudo apt update
[sudo] password for leon:
Hit:1 cosmic InRelease
Hit:2 bionic InRelease
Ign:3 stable InRelease
Hit:4 stable Release
Hit:5 cosmic InRelease
Get:6 cosmic-security InRelease [83.2 kB]
Get:7 cosmic-updates InRelease [83.2 kB]
Hit:9 cosmic InRelease
Get:10 cosmic-backports InRelease [74.6 kB]
Fetched 241 kB in 11s (21.2 kB/s)
Reading package lists… Error!
E: Problem parsing dependency 21
E: Error occurred while processing kmail (NewVersion2)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
[email protected]:~$ Traceback (most recent call last):
File “/usr/share/appgrid/”, line 163, in
File “/usr/share/appgrid/”, line 52, in rebuild_db
from appdata.apps.aptapp import AptApp, get_apt_pkgnames, get_desktop_files
File “/usr/share/appgrid/appdata/apps/”, line 13, in
cache = Cache()
File “/usr/lib/python3/dist-packages/apt/”, line 138, in init
File “/usr/lib/python3/dist-packages/apt/”, line 198, in open
self._cache = apt_pkg.Cache(progress)
apt_pkg.Error: E:Problem parsing dependency 21, E:Error occurred while processing kmail (NewVersion2), E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.

I recommend that you install 16.04.x LTS. It is fast, stable and reliable. I have so far discovered no compelling reason to upgrade to 18.04.

I hope the 18.04 disaster proves to be a one-off anomaly, and 20.04 returns to 16.04 level of quality.


Disaster ? What disaster ?
It is so stable that I can get virtually infinite uptime.

All I am seeing here is system misuse, with a damaged file system and probably some mess coming from random PPA.

1 Like

Ubuntu MATE 18.04.1 LTS (Bionic) best version ever…

Try to install again, take it easy… check the details carefully. Not all problems can be related to the system…

Good Luck! :slight_smile:

Evidently, my mobo, (Gigabyte GA-990fxa ud3 Rev. 5) has an USB controller with known issues with Ubuntu. USB downloads are extremely slow. In 18.10, USB wouldn’t work at all. At least in 18.04, I have some use of USB. Peripherals work fine, just file copy is horrible.

But, at the end of the day, I am SOOO pleased with Ubuntu and the Linux community, that I can deal with a slow thumb drive. Gives me an excuse to go mobo shopping. lol

Thank you all for your help and advice. In the end, I wiped the drive and re-installed 18.04. I may try the upgrade again in a couple of months, but for now, I just don’t have the time to mess with it.

Thanks again! :smiley: