Caja failing on copying big files over samba

Hi all,

I’m not sure if this problem is really related with caja but i realized that i cannot copy files bigger than 2.1G to my samba share which is also running a linux debian based image. At 2.1G, i always get an error prompt saying “Invalid argument”. I have mounted manually the share (without caja) and it worked fine, so the problem is not on the server. I saw, that using directly “gio copy” from the command line, gave the same error.
Does anyone has the same issue? If so, any help would me appreciated.

Version: 18.04


It seems to me there’s a bigger problem here, I’ve had similar problems copying using Lubuntu, Ubuntu MATE and Xubuntu. They don’t need to be big files and it seems to be common to Caja, PCManFM and Thunar. The common denominator seems to be Samba, and I’ve been aware of this problem for probably a year but haven’t been

However, I’m probably also talking about a different problem altogether – my symptom is that sometimes copying files just hangs, it can be a couple tiny files, no reason for it to take more than a second. I get no message, it just never finishes. I’m learning that I should just use ‘cp’ instead of file managers.

Hmm i see,

But it seems to be a different problem. For me it always happens at 2.1G but maybe it can also happen with smaller files, but it never happened though. I don’t suspect on samba because if i mount the samba share on the command line and use cp, then it works…
I have an arch linux installation (also with caja) which uses a much recent version of libglib. I want to try the same thing there to see if the issue persists…