Caja load times... unbearable!

Hello all,

I love mate and all its goodness, but the one thing thats always on my mind is the ever persistent load times when I launch Caja. It takes 3-5 seconds to open up after I click on it. It drives me batty. I’ve done some research on it and it appears that this was coded intentionally for some reason or another, there is a work around I read. But to be honest I really dont want to dig into the system files and start changing things. The thing is, this bug fix is years old, haven’t they had a chance to correct it by now? Its not just this computer, I’ve tried it on two others, along with other versions of Mate.

Any feedback? All the threads I’ve read about it are over at least three years old. I just wonder what the current word is out there.

Thanks!

I dont seem to get this. It opens instantly for me.
Have you tried: sudo apt-get install --reinstall caja
Do you get this with any other file manager like Thunar?

Hi,

Caja opens within 2 seconds on my PC, I’m using Ubuntu Mate 15.04 Beta 2, which version of Mate are you using and how old is your PC, size of RAM and CPU?. :smiley:

Have you done a full system update with your software sources download location set to “Main”?:

Mostly referring to initial loading time after a reboot, after that it is quicker.

I do notice that on first opening Caja, after initially logging in, it can take a second or two to load. However, for the rest of the session, it loads instantly. For me, that’s a non-issue. I suspect it is a non-issue for the Mate devs as well.

That’s strange, do you have icons on your desktop? Because if you do, Caja is already running and rendering the desktop, and it should load fast as soon as the desktop is visible.

I can confirm, at least on my machine, that I do indeed experience a slight lag on loading, say, my home folder after initial boot-up and login. However, I can also say that this lag is barely a second or two and, following that, all folders will load more or less instantly for the rest of that session. Like I said previously, for me it’s a non-issue and I suspect the same may be said for the Mate devs.

I also get a slight lag but I get it also when using the mint Mate menu. Both of these things were in Linux Mint when I was using it too. It is strange since I also use Scientific Linux and I never get this on there (and it’s a little heavier too). I’d suspect it’s a non-issue for the devs, there are plenty of bigger fish to fry.

Perhaps it is indeed meant to be like this, I’m too lazy to dig in it’s code to find out :smile:

I am sorry to hear that Caja crashes so much for you, It’s certainly the first time I have heard of anyone reporting as such. Similarly for Marco. Which makes me wonder is there is some specific aspect of your system that is causing these crashes?

Did any of you that have a problem with Caja follow this advice?:

(I know that you all most likely did follow the advice on the link but I have to ask!).

Also, check Mate Tweak and see what your window manager is set to and change it:

Well, to follow up from my original post, I’ve had another distro on my main box for testing and decided I had enough and went back to Ubuntu-Mate. Seems Caja load times, even after initial boot are much quicker then before. Odd since both installs were 14.04.2.

With that, all my issues are resolved. Ubuntu Mate just keeps getting better every time I use it.

Thanks all for the replies… :smile:

1 Like