Caja not starting with xbindkeys

I’ve installed xbindkeys and in the ~/.xbindkeysrc I have the following binds

  Mod2+Mod4 + 1 + Release

  Mod4+2 + Release

  Mod4 + 3 + Release

The terminal and Firefox work, Caja doesn’t. Unless I restart xbindkeys: killall xbindkeys && xbindkeys
So for some reason it doesn’t work on boot.

So I tried too check if caja can be found

"whereis caja >> /home/janw/caja.txt && caja"
  Mod4+2 + Release

But it always logs the same , before and after restarting it or running it manual.
I tried different programs, different key binds. Only caja appears to be a problem.
Does anybody have an idea where to look next?

I'm not running xbindkeys, but I can think of couple of things to try.

You have some sort of auto-start for xbindkeys, try adding a delay to it. Could be booting too early for caja.

Could the default shortcut be interfering? Disable it.

I already disabled the home folder.

I edited the startup command to:

sleep 30 && xbindkeys_autostart

In the weekend I’ll test this and if it works figure out a more realistic delay.
I’ll let you know.

1 Like

I tried a sleep. That wasn’t allowed, no response.
So I wrapped it in a .bash script and put that in the command.


notify-send "sec 1"
sleep 50 && xbindkeys && notify-send "DELAY"

The notifies work, But the problem with caja is still here :frowning:

Any other ideas?