Cannot unmount primary to re-partition from live USB GParted

I have one single LVM with Ubuntu MATE installed as my only OS (see pic) which I wish to split into two, one for the OS and one for my data. I have tried to re-partition from the live USB using GParted but am unable to unmount the volume. If I close GParted I can eject/unmount from the file explorer, but then when I open Gparted again the volumes are locked (with the key icon) and have disappeared from the file explorer menu.

I would appreciate any help with this.

Thanks (hopefully) in advance.

Hi @jonsalt1973,

did you first unmount the 3rd partition (/dev/sda5) and then /dev/sda2 which is the extended partition, both have to be unmounted before you can do anything!. :smiley:

See also (it may not help because there is no info about LVM partitions!):

This may also be of some help?:

Thanks but that didn’t work for me. I have had to bite the bullet and backup, wipe it all, and start from scratch by partitioning and then a clean install.

1 Like

Okay, at least you have it up and running again in the meantime I assume?.

I have marked this thread as solved!. :thumbsup:

Ironically it seems the LVM, which advertises itself in making guided partitioning easier, is the thing that prevents the volumes from being unlocked. I did a clean install without using LVM, and was then able to resize and create partitions at will from the live USB. All good now. I appreciate the help.

1 Like

HI @jonsalt1973,

I personally don’t use LVM partitions as I have often had trouble in the past, for the same reason; I don’t use encryption either!. :smiley: