Canon scanner pixma not working

Hi, I’m taking a view to ubuntu-mate in the last week, coming from Xubuntu experience in the last 3 years.
I’m really satisfied about mate, particulary for the graphic side: no tearing, no scratch on the screen, good.
The problem I can’t resolve is to make my multifunction Canon Pixma MG5350 working as a scanner.
Printer is connected and working via wifi, but when I try to scan a page the result is:
"Error opening device: opening device ‘pixma:MG5300_192.168.0.30’: Invalid argument."

This is the output of scanimage -L
[email protected]:~$ scanimage -L
device `pixma:MG5300_192.168.0.30’ is a CANON Canon PIXMA MG5300 multi-function peripheral
But if I try scanimage -T:
[email protected]:~$ scanimage -T
scanimage: open of device pixma:MG5300_192.168.0.30 failed: Invalid argument

I never had such a problem in Xubuntu (nor 14.04, nor 16.04).
Searching the web I’ve seen that the bug can be in the libsane version, particulary the 0.17.18.
Is this version still in use in mate?
Any idea or help to solve?
Thank you in advance.

Hi @Ansano,

take a look at the link below and see if you can find your drivers on the Canon Asia site?:

Thank you, wm, I had still read your post in other topics on the argument. I’ve installed Canon drivers from asian support, but it doesn’t help me to have my scanner working.

Hi @Ansano,

have you installed the package “xsane”?, to install via the terminal (Ctrl + Alt + t):

sudo apt-get install xsane sane

Have you tried using “Simple Scan” to see if that can pick it up?. :smiley: (Applications > Graphics > Simple Scan). :smiley:

1 Like

Hi wolfman, thanks for your attention.
This is the output of xsane (I left out a long series of …giving up…):

[email protected]:/$ xsane
[sanei_debug] Setting debug level of pixma to 255.
[pixma] pixma is compiled with pthread support.
[pixma] pixma version 0.17.18
[pixma] Scanner model MP150(Canon PIXMA MP150) not found, giving up! MG5300 series
[pixma] Scanner model MP170(Canon PIXMA MP170) not found, giving up! MG5300 series


[pixma] Scanner model found: Name MG5300(Canon PIXMA MG5300) matches MG5300 series
[pixma] pixma_collect_devices() found Canon PIXMA MG5300 at bjnp://192.168.0.30:8612
[pixma] pixma_open(): Canon PIXMA MG5300
[pixma] pixma_connect() failed EINVAL
[pixma] pixma_open() failed EINVAL
[pixma] pixma_close(): Canon PIXMA MG5300

Simple Scan simply tells me to search for another scanner :slight_smile:
Anothe scan utility, gscan2pdf, is a bit more verbose and says:
Error opening device: opening device ‘pixma:MG5300_192.168.0.30’: Invalid argument.

Hi @Ansano,

I am not really sure what is wrong if you have the drivers installed it should be okay, try moving the USB cable to another port but make sure you swap them over when the PC is off!, restart and try your scanner again. :smiley:

@wolfman,
Canon Pixma is not connected via USB, but on WiFi.
I still tried to connect via USB, but the result is the same: I can see and use the printer, not the scanner.

If that is the case, open Control Center > Administration > Printers and remove your printer, restart and add it again but add it using a USB cable, you can play around with the WiFi afterwards!. :smiley:

@wolfman
I’ve just done what you say. Removed the old printer config,restarted the PC and connected the Pixma device via USB.
Ubuntu has got the new device and connected it. The address is now “usb://Canon/MG5300%20series?serial=2AD332&interface=1”
But the result is nearly the same. Printer is working ok and scanner is not.
The output of gscan2pdf is now more syntetic: “Error during device I/O”.

Does your printer/scanner have a control switch on its panel?. :confused:

Also, try downloading the package from the link below and it should work after that (said he hopefully!). :smiley:

http://support-sg.canon-asia.com/contents/SG/EN/0100395402.html

(MG5300 series IJ Printer Driver Ver. 3.60 for Linux (debian Packagearchive)).

Package downloaded, installed, printer config removed. Restarted PC and printer, got new config and…
still the same, printer is working, scanner is not.
Same message from gscan2pdf:
“Error opening device: opening device ‘pixma:MG5300_192.168.0.30’: Invalid argument”

Perhaps this can help -

Thanks, mdooley. The one you link is the very first one from where I started searching for a solution. But the post is dated more than one year ago, and versions evolved.
I don’t arrive to understand wich version is in use now.
If I ask
[email protected]:/$ locate sane-pixma
/usr/lib/i386-linux-gnu/sane/libsane-pixma.a
/usr/lib/i386-linux-gnu/sane/libsane-pixma.la
/usr/lib/i386-linux-gnu/sane/libsane-pixma.so
/usr/lib/i386-linux-gnu/sane/libsane-pixma.so.1
/usr/lib/i386-linux-gnu/sane/libsane-pixma.so.1.0.25
/usr/share/man/man5/sane-pixma.5.gz

What do you think about?

Are you sure that your wireless scanner is located at 192.168.0.30 ?

What does scanimage -T in terminal give you?

[email protected]:~$ scanimage -L
device `pixma:MG5300_192.168.0.30’ is a CANON Canon PIXMA MG5300 multi-function peripheral

[email protected]:~$ scanimage -T
scanimage: open of device pixma:MG5300_192.168.0.30 failed: Invalid argument

1 Like

Post your question on http://askubuntu.com/ and see if they can provide better assistance.

Good luck Ansano.

1 Like

Hi @Ansano,

as I don’t have a Canon printer myself, it is difficult for me to help you further, try following @mdooley’s advice and ask Ubuntu!. :smiley:

@mdooley
@wolfman
Ok, thanks anyway!

1 Like