Can't see NVME M.2 drive for fresh install

I have an x399 Taichi motherboard and an NVME M.2 drive. When I boot from a thumb drive for an install, it doesn’t see the nvme drive. I’m able to test drive Ubuntu Mate, but not install it. Moreover in /dev I don’t see any nvme devices. Any ideas?

Typically you need to at least format this thing so that it has a partition table to enable it to be discovered.

A few days ago, I physically installed a SSHD on my old laptop using a mounting device that replaced my DVD drive - my bios saw it but nothing else I tried (and I tried a lot of stuff) saw the new drive. I had to connect it to the laptop using a USB cable connector and then I could see it using Gparted or Partition Magic.

I suggest that you do likewise. Let us know if this was a good way to go.

Jeez! I just looked up nvme to usb cable and they cost bucks. I’d check your BIOS to see if it recognizes the M.2 drive, try re-seating it and check BIOS again. Does your new machine have a working drive on it? Have you tried GParted to see if it recognizes the hardware? Good luck @MikeyBee

In order for the Ubuntu 18.04 Installer to see a internal NVMe SSD on some machines you may need to make the following change in the system BIOS.

  1. Boot into the BIOS Setup on your machine.
  2. Find the System Configuration in the BIOS Setup.
  3. Find SATA Operation and select AHCI.
  4. Restart the computer and the Ubuntu installer should now detect the NVMe SSD.

I have read that Windows won’t be able to boot in AHCI mode. If your replacing Windows then this is not a issue. However, if you are wanting to dual boot with Windows, then you may find yourself in a scenario where you have to change the SATA Operation back to it’s original value each time you want to boot into windows.

Please make note of the original value for the SATA Operation before you change it, in case you need to switch it back in order to boot into windows later, or if this does not resolve the issue you are facing.

1 Like

I have had exactly the same problem on my new Ryzen 2 setup and my solution was to upgrade my BIOS. I will also mention that upgrading the BIOS can be a fairly easy thing to do on some new motherboards.

1 Like

To be more exact concerning AHCI mode, Windows will not be able to boot in AHCI mode, unless it was in that state when it was installed. So technically it would be possible to dual boot Ubuntu and Windows after the SATA Operation was changed to AHCI, with out having to switch this mode in the BIOS each time Windows was booted, by reinstalling Windows after the SATA Operation was changed to AHCI. However, this would require a Windows installation disk, and all the required drivers for your system. If your a system builder then you will already have theses requirements. If you are working with a OEM machine then you will not because most OEM’s no longer supply Windows installation disk, opting for a system restore partition instead.

I’ve been avoiding this issue for awhile now. I put in a SATA SSD, and it works fine, but I plan to get back to it. I have this problem using the latest bios. It may have something to do with aspm. At least there are dmesg entries that suggest it. I found an item on the web saying that pressing E at boot and entering pcie_aspm.policy=powersave then adding it in grub should fix the problem. When I get my ambition back for this, I’ll give it a try. In the mean time, I’ve been battling with django. :slight_smile: