Chromium/Chrome fails to set as default in 15.10

Unfortunately, since upgrading Ubuntu MATE 15.04 to 15.10, Chromium keeps prompting me if I'd like to set it as the default browser, despite being told multiple times it can.

It's set as the default web browser in: System → Preferences → Personal → Preferred Applications -- switching preference to Firefox and back didn't help.

When ran from the terminal, this line appears each time "Set as default" in Chromium is clicked:

xdg-settings: unknown desktop environment

Is there a way to fix this? Thank you in advance. :smile:

Same problem here !
I don’t found any solution yet :frowning:

Same problem here! Had the exact same problem with opera browser.

Have you tried setting it in terminal using update-alternatives?

sudo update-alternatives --config x-www-browser

Sadly, this doesn't make a difference.

When running:

xdg-settings get default-web-browser

It correctly reports chromium-browser.desktop as the default browser. When running:

x-www-browser

Chromium opens up too, but for some reason Chromium (and in @kakosf's case. Opera) itself is having problems reading/setting the defaults. :confused:

I also run chromium and tried changing my setting around. I now see what you mean.

I found that I can edit the mimeapp.list to show the correct browser.

xdg-mime default google-chrome.desktop text/html
xdg-mime default google-chrome.desktop x-scheme-handler/http
xdg-mime default google-chrome.desktop x-scheme-handler/https
xdg-mime default google-chrome.desktop x-scheme-handler/about

This can be verified with code

xdg-mime query default text/html
xdg-mime query default x-scheme-handler/http
xdg-mime query default x-scheme-handler/https
xdg-mime query default x-scheme-handler/about

I have not tested this any further, no time till tonight.

I had the same problem with Mate 15.04 and Google Chrome. Now I have 15.10 and problem still there. Did you resolve this @anon42388993?

No Steve, I have not.

Same problem here. Very frustrating.

A fellow user has reported this as a bug to Launchpad:
https://bugs.launchpad.net/ubuntu-mate/+bug/1516232

Click the “This bug affects me too” to raise it’s heat (providing you have a Launchpad account)

Uninstalling Firefox (default browser) did the trick for me. now i have Chrome and midori. Chrome work as default one.

Is the box in FireFox > Edit > Preferences > “Check if FF is the standard browser” ticked?

I found a fix for this and it works for me with Chrome :slight_smile:

found at 15.10 - google-chrome-stable keeps asking if it should be set to default - Ask Ubuntu

UPDATE April 5th 2016 (Working fix!)

A fix has been proposed on launchpad that apparently did the job for a couple of people:

To apply the fix, change line #198 in the file /usr/bin/xdg-settings
from
command="grep -E "^Exec([[^]=]])?=" "$file" | cut -d= -f 2- | sed -e 's/ .$//'"
to
command="grep -E "^Exec([[^]=]])?=" "$file" | cut -d= -f 2- | sed -e 's/ .$//' | head -n 1"

1 Like