Chromium crashes when starting. Segfaults?

Hi, just recently this started happening for no apparent reason.

I am running Ubuntu Mate on a Raspberry Pi2. This is the output from terminal:

[email protected]:~$ chromium-browser
Segmentation fault (core dumped)
[email protected]:~$ [4066:4066:0324/] InitializeSandbox() called with multiple threads in process gpu-process

I have already tried re-installing chromium-browser and deleting the configuration files for it.

Any ideas, thanks.

I can comfirm that is is doing the same exact thing here with the same message.

I have also tried the same fix (uninstall Chromium-browser, and even removing the chromium browser folder in (homefolder)/.config … I reinstalled it and same segment fault message as the original poster

1 Like

Same here I think last update have something wrong. I go back to previous version and it works.

Try updating again, I just did and there was a new version included!. :smiley:

Fully updated, get a Sandbox error

[1:1:0327/] Check failed: IsFileSystemAccessDenied().
#0 0x000073d5373a base::debug::StackTrace::StackTrace()
#1 0x000073d665b2 logging::LogMessage::~LogMessage()
#2 0x0000732e32ae sandbox::SetuidSandboxClient::ChrootMe()
#3 0x000075f76f34
#4 0x000075d0eb92
#5 0x000075d0f06c
#6 0x000075d0de76 content::ContentMain()
#7 0x000054d1e51c
#8 0x0000723c3772 __libc_start_main

Received signal 6
#0 0x000073d5373a base::debug::StackTrace::StackTrace()
#1 0x000073d53a2c
#2 0x0000723d2230
#3 0x0000723c39a6
#4 0x0000723d161e gsignal
#5 0x0000723d2312 abort
#6 0x0000723fb3ac _IO_file_xsputn
#7 0x0000733a4c40 gfx::ScaleToCeiledSize()
[end of stack trace]

Okay, try the following, remove Chromium and then change your software sources download location and then re-install it and see if that helps?. :smiley:

Ubuntu Mate Update Guide

I have tried updating Chromium and it is still not working for me.

Please how can I fix it ?

Here is the output from terminal again:

[email protected]:~$ chromium-browser
[1766:1766:0328/165027:ERROR:logging.h(813)] Failed to call method: org.freedesktop.DBus.ObjectManager.GetManagedObjects: object_path= /: org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.bluez’: timed out
Segmentation fault (core dumped)
[email protected]:~$ [1813:1813:0328/] InitializeSandbox() called with multiple threads in process gpu-process


Chromium browser works fine on my version of UM 16.04!.

I don’t know really what to suggest apart from looking at this old thread which might help you?:

If you have a 64 bit version of Ubuntu Mate, install Google Chrome 64 bit (32 bit is no longer supported!):

I’m using a Pi2. Many other users said they were experiencing the same problem, please can I know how any of you resolved it ?

This problem came out of nowhere. What is the proper procedure to update chromium to latest version or roll back to a previous version or to update Ubuntu Mate on the pi as well ? Thanks

I have the same problem, pi2 and segmentation fault, and I don’t know how can I rollback to a chromium version worked.

Anybody know what was the last version that works?

I have the same issue with ubuntu server minimal for Raspberry Pi 2 (downloaded from

To downgrade:
From command line (terminal) you can run

apt-cache policy chromium-browser

Now you can see the versions that are available.

chromium-browser: Installed: 45.0.2454.101-0ubuntu1.1201 Candidate: 49.0.2623.108-0ubuntu0. Version table: 49.0.2623.108-0ubuntu0. 0 ... etc etc

At least for me, there are 2 versions available, where the oldest works.

I had to remove the newest with
sudo apt-get remove chromium-browser chromium-codecs-ffmpeg-extra chromium-browser-l10n
and then install the older one with
sudo apt-get install chromium-browser=45.0.2454.101-0ubuntu1.1201 chromium-codecs-ffmpeg-extra=45.0.2454.101-0ubuntu1.1201 chromium-browser-l10n=45.0.2454.101-0ubuntu1.1201

(Edit to add Aworan’s instructions to block chromium updates)
Block updates with
sudo apt-mark hold chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n

Last working version is 48 but is not available with apt-get install.
So I think the best to downgrade to last working version is open a terminal then :

sudo apt-get remove chromium-browser chromium-codecs-ffmpeg-extra chromium-browser-l10n


sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu0.
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu0.
sudo dpkg -i chromium-browser-l10n_48.0.2564.116-0ubuntu0.

Then you can block updates on chromium packages with :

sudo apt-mark hold chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n

When a new working release will be available you can unblock packages updating with :

sudo apt-mark unhold chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n
sudo apt-get upgrade



1 Like

i have been battling this for the last few days and it seems that the reason for this happening is the --enable-pinch flag.

if i open an xterm and type in chromium-browser --disable-pinch chrome will launch.
if i then go on to set the flag in chrome://flags/#enable-pinch to disable i can launch chromium from inside the xterm without the switch.

however - when i launch X and try to start it from the command line this happens:-
startx /usr/bin/chromium-browser --kiosk
which launches
/bin/sh /usr/bin/startx /usr/bin/chromium-browser --kiosk
which in turn launches
xinit /usr/bin/chromium-browser --kiosk
which the launches
chromium-browser --enable-pinch --kiosk

and the #$#@!#@[email protected]#$!$ --enable-pinch is back!!!

how do you set a chromium-flag for every user?

I'm not sure but maybe users & groups in the Control Centre?, you could also try adding the disable-pinch command to Startup Applications?:

i found what it was
has a variable want_touch_pinch set to 1 by default. this was triggering the adding of the --enable-pinch
no matter what you set anywhere else, it was being added by this script and over-rides the disable flag

setting it to 0 solved the issue.

perhaps a good question now would be - why is this script even messing with --enable-pinch ?

1 Like

So when will this issue be resolved ? With whom does the fault lie ?

I guess canonical lauchpad arm build, I will try to report the problem here if it is not already.
It don’t work in mate 16.04 beta 2 too :frowning:


A bug report was already open in launchpad, I added another comment.
Maybe you can create an account to and click “this bug affect me” to make the counter grow :wink:
I hope they will fiw it soon !

Thanks, I’ll do that !

So I am running rpi2 and install chromium and it crashes. I am running 16.04 beta 2. I did the updates no luck? Any ideas?