Cmus doesn't list any tracks in Ubuntu MATE

My preferred music player of choice is cmus. But unfortunately, it doesn't seem to work properly in Ubuntu MATE. As you can see from the screenshot, there are no tracks listed in the right-hand column of the library view. I have another computer that runs Arch, and it works properly there. So I'm thinking this is either something specific to Ubuntu MATE or Ubuntu proper. I looked for bugs in Ubuntu's launchpad but didn't find any.

Does anyone else use cmus and have worked around this issue?

Looks like I solved the problem, it turns out that the version of cmus included in Ubuntu’s repositories just doesn’t work properly. I compiled from source and it’s fine now. In case anyone else has this issue, this is what I did:

Installed the following packages:
libncursesw5-dev libpulse-dev libjack-dev libsamplerate-dev libopusfile-dev libavformat-dev libcue-dev libasound-dev libflac-dev libvorbis-dev libwavpack-dev libfaad-dev libmp4v2-dev libmad0-dev

Downloaded cmus:
https://cmus.github.io/#download

Configured like so:
cd cmus* && ./configure CONFIG_ROAR=n

And then installed:
make && sudo make install

Hopefully this helps someone else that uses this awesome player!

2 Likes