Crashing at Log in

For the past couple of days MATE has been crashing after I enter my log in password - the screen freezes, no cursor control. The issue only seem to affect kernals 4.13.0-32/36, and I can log in normally with 4.13.0-31 and prior. I’m running 16.04 and haven’t noticed any other problems after logging in.

Any ideas on what’s causing the problem, or how I can check for errors?

Try dmesg (and /var/log/syslog) … do they give a clue?

running dmesg didn’t turn up any obvious errors, however the print out is pretty big, and if something was wrong I’d likely not pick up on it.

Here’s what /var/log/syslog had to say:

Mar 5 15:09:07 aaron anacron[1071]: Job cron.daily' terminated Mar 5 15:17:01 aaron CRON[3292]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly) Mar 5 15:18:19 aaron anacron[1071]: Jobcron.monthly’ started
Mar 5 15:18:19 aaron systemd[1]: Starting Cleanup of Temporary Directories…
Mar 5 15:18:19 aaron systemd-tmpfiles[3316]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path “/var/log”, ignoring.
Mar 5 15:18:19 aaron anacron[1071]: Job `cron.monthly’ terminated
Mar 5 15:18:19 aaron anacron[1071]: Normal exit (2 jobs run)
Mar 5 15:18:19 aaron systemd[1]: Started Cleanup of Temporary Directories.
Mar 5 15:20:03 aaron ntpd[1504]: local addr 192.1 ->
Mar 5 15:27:54 aaron ntpd[1504]: local addr 192.1 ->
Mar 5 15:27:59 aaron ntpd[1504]: local addr 192.1 ->
Mar 5 16:17:01 aaron CRON[3930]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Mar 5 16:18:38 aaron org.freedesktop.Notifications[2061]: ** (mate-notification-daemon:3936): WARNING **: Unable to load theme engine ‘Coco’
Mar 5 16:22:40 aaron com.canonical.indicator.application[2061]: (process:2402): indicator-application-service-WARNING **: Application already exists, re-requesting properties.


It’s now crashing on all kernals, but only when I hit Enter after my password. Clicking Log in with the mouse works fine. I’m also getting a Stephen Hawkins voice list the possible options on the log in screen. Never heard this before today.

Hi Huxley,

try running “dpkg” per the update guide and get back to us:

Ubuntu Mate Update Guide :smiley:

Hi, Wolfman.

Thanks for replying. Unfortunately, I can’t get my PC close enough to my router to try the cabled network > dpkg method, however I ran all of the following commands in terminal:

sudo apt-get update && sudo apt-get dist-upgrade

sudo apt-get --fix-missing install

sudo apt-get --fix-broken install

sudo dpkg --configure -a

sudo apt-get install -f

A whole bunch of files were added / fixed / removed, however after rebooting there was no change to the log in issue. I’m still getting the annoying Stephen Hawkins voice, and hitting Enter after my password still causes a crash.

you may have the speech-dispatcher running at boot.
See this link to disable and try again, there should be no voice.

Nope, that wasn’t it, either. I checked in Universal Settings and also
The speech kicks in as soon as I type the first character of my password and ends once I click Log In. That’s the only time I ever hear it.

System, Preferences, Personal, Startup Apps do you have Orca screen reader enabled? disable it, reboot and try …

Yes, I checked that. It’s definitely disabled.

HI Huxley,

it sounds like you have at least your PC running without crashing now?. Make sure you have "Assistive Technologies" switched off in Control Centre > Assistive Technologies > Enable Assistive Technologies and then your PC should stop talking to you!:


Hi, Wolfman

Just checked and it was already disabled. My PC only talks during Log In which is bemusing more than anything else. I’d like to get to the bottom of why it crashes after using Enter but so long as I remember to use the mouse it’s not really an inconvenience. I just hope that it isn’t a symptom of something more serious

Hi Huxley,

try running the following terminal command (Ctrl + Alt + t) which has an added “-f” on the end to force any missing dependencies!.

sudo apt update && sudo apt dist-upgrade -f

Try the following if the one above doesn’t work!:

`sudo apt-get update && sudo apt-get dist-upgrade -f

Another question, what did you use to do your install, USB or DVD?. :smiley: `

Hi, Wolfman

Sorry for the late reply, I’ve been on vacation… The additional -f didn’t seem to make a difference, unfortunately. I’ve also reinstalled the desktop, but nothing seems to work.

I installed from a USB, however that was at least 6 months ago, and I didn’t experience any Log In problems until a week ago. Do you think ugrading to 17.10 would be a potential cure? I’m about ready to format my hdd and do a fresh install anyway.

Hi Huxley,

I am running 17.10 (and 18.04) and don’t have any problems, give it a try, you won’t have to wait long for the 18.04 final anyway!. :thumbsup:

1 Like

Upgraded to 17.10 and Logged In without any issue.
Problem solved

Thanks for all the help and advice Wolfman

1 Like