Ctrl+Alt+T doesn't open the terminal

Very odd this, pressing Ctrl+Alt+T no longer open the terminal. It used to but today I turn the PC on and the shortcut has stopped.


try changing your software sources download location to “Main” if it isn’t already, if it is, change it to a different location, reload and do another update, see the update guide for further help:

Thanks but that hasn’t worked. The MATE terminal still doesn’t open with ctrl+alt+t.

Have you enabled Compiz? If so that tends to break it instantly.

I eventually figured out that compiz was to blame. Still works on my Acer C720 which doesn’t have compiz enabled.


Compiz seems to be a lot of trouble for @Wimpy

DEAR PEOPLE FROM THE FUTURE: Here's what we've figured out so far ..

I also went searching for an answer to this problem and while I didn't find it here I did figure out the answer, so I want to share it with others here:

In CCSM (CompizConfig Settings Manager) open the Mate Compatibility setting under General. You may need to enable it first, which will give a warning that enabling Mate Compatibility will disable Gnome Compatibility. Feel free to ignore the scary warning.

Once in the Mate Compatibility plugin you want to click on the Commands tab and look at the Terminal command line section, underneath of which is a keyboard shortcut option, you can use to set the combo to open the Terminal. Likely in enabling Compiz somewhere along the line this setting was cleared accidentally. Just open the applet and set the key combo you prefer to use.

I apologize for bumping such an old thread but since it's showing up near the top of my Google search on the issue, I figured it a good idea to add a solution for others who come after me.

I don't want to leave anyone like this guy....


Thank you so much, person from the past. This helped tremendously.

1 Like

New update from the future:

I had this same problem on Ubuntu 16.04, but enabling the fix in Ubuntu Mate didn't work.

The problem on my end was that I'd recently updated python. Fix was found here: https://askubuntu.com/a/978471

1 Like