Disable wifi power management MATE 18.04

I want to set my WIFI so it wll not turn off when I close the lid.

In Ubuntu its
but that setting does not exist in Mate.

Where you guys hide it :slight_smile:

1 Like

Hey man,

I am also experiencing this too…can you please tell me how did you fix it? Really need this :D. Here is a upvote too haha.

It turns out wifi power management is off by default and my occasional lack of wifi after suspend is due to something else. Could be something to due with my wlp setup.

You can check your status in terminal:


The output will look like this:

wlp3s0    IEEE 802.11  ESSID:"xxxxxx.xxx"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:02:6F:FB:BE:4E   
          Bit Rate=48 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=54/70  Signal level=-56 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2675   Missed beacon:0

On my Raspberry Pi 3 B+ running Ubuntu Mate 18.04 LTS the wifi power management is always on after I boot up. I turn it off with sudo iwconfig wlan0 power off after each reboot. The scripts I've looked up and tried so far don't work. There's so many. It's crazy.

Me again. I found this on another website and it worked:

Open this file with your favorite text editor, I use nano here:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

By default there is:

wifi.powersave = 3

Change the value to 2 . Reboot for the change to take effect.

Possible values for the wifi.powersave field are:

NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting

1 Like