Dual Boot Doesn't Show in Grub Menu

I installed Ubuntu Mate 16.04 alongside Linux Mint 17.3. When I rebooted after installation and called up the grub menu, Ubuntu Mate was the only option. What gives? Is there a fix for this? Thankfully I used my Lenovo Thinkpad test laptop for this installation.

I have done that in the past, should of worked. Are the partitions all there?

sudo fdisk -l

Yes. I have done it too many times also.

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 122855593 122853546 58.6G 83 Linux
/dev/sda2 122857470 156301311 33443842 16G 5 Extended
/dev/sda5 152178688 156301311 4122624 2G 82 Linux swap / Solaris
/dev/sda6 122857472 152178687 29321216 14G 83 Linux

Looks like you have two installs (sda1 & sda6). Try updating grub and see if it picks up on your Mint install.

sudo update-grub

An easy way to solve a boot problem is with boot-repair.



For a closer look there is boot-info-script which is included in boot-repair


or can be installed as a stand-alone package.

sudo apt install boot-info-script

You can also try the following terminal command (Ctrl + Alt + t):

sudo apt-get remove grub-pc && sudo apt-get install grub-pc :thumbsup:

Boot repair did not work as Ubuntu Mate again showed up in the Grub menu as the only option. Therefore, I reinstalled Linux Mint 17.3 Mate. At this point I have to say that Ubuntu Mate 16.04 LTS is simply not ready for production when you already have a distro installed and want to have a dual boot machine. In addition, the shutdown time was about 20 sec. on my laptop compared to Linux Mint’s <5 sec. Ubuntu Mate has a long ways to go before it will ever be as refined or as stable as Linux Mint. 'Nuff said.