Epson WiFi printer

Hi there…have a fresh install of Mate 14.04 and had an Epson WiFi printer that installed initially but they for some reason became disconnected now I am not able to find the printer in the printer settings manager. Not sure what is going on here since it worked without a hitch for about 3 weeks. I also have another issue which I will bundle with this one, sometimes the screen does not “wake up” forcing a reboot, is there any solution to this already?
thanks in advance!


have you run any updates recently and maybe a kernel update?, try changing your software sources download location then update again and see if that works:

You can also try running this terminal command (Ctrl + Alt + t) which might fix it if it is only a case of missing dependencies:

sudo apt-get update && sudo apt-get dist-upgrade -f

that didn’t see to work unfortunately. the printer will not show up under network printers and it keeps asking for a workgroup host password which I have no idea what that is

Did you install it with the Linux drivers from the Epson site? My Epson WF-3540 would do the same thing until I downloaded the correct drivers from Epson…and ran the install over again…

Run the printer network settings and make note of IP address, etc.

BTW…Epson has quite a list of drivers for printing, scanning, and faxing…look carefully at your choices…you will need to install the ISCAN DATA driver BEFORE the scanning driver or it will error off…GDebi worked well for me for the install…keep a copy of the drivers in Downloads and in your backup and you can use them again quickly if you change distros…HTH

thanks for the help on this one, still no answer though…did download the correct drivers and tried to re-install, with no luck. Even jumped into the IRC for the first time ever today and still wasn’t able to figure it out, Martin even jumped in and tried to help. I really like this distro, but I would almost rather go back to my 12.04 spin that worked out of the box…not blaming Ubuntu Mate by any means, just one of those things that makes me want to bang my head on the desk.


first go to Control Center > Hardware > Printers and remove what printers you have showing, then restart making sure the printer(s) are switched on and connected via a USB cable, then go back into the Control Center again and add the printer(s) and see if that works for you!. :smiley:

Its worth a try!. :smiley:

So I got it to work! well sort of, can print wirelessly from native applications but it saves it to a pdf from the web…


I don’t have an Epson printer but my HP comes with a settings manager (hplipgui is the package name) and I can make changes there, does Epson provide a settings manager under Linux?. :smiley:

I’m not quite straight on your hook-up. Are you doing it USB or wireless?

trying to do a wireless hook up, it did work for about three weeks and now cannot find the printer that was there before, and I did search for a settings manager for the epson with no luck wolfman

Try this, there are other links for epson too: