Erratic performance of Plank

Hi!!

I’ve a problem with Plank and Ubuntu Mate 16.04. When it’s running (regardless of whether it’s enabled Compiz or Marco) the performance is really bad, some apps have choppy and sluggish minimize and maximize animations, others like Caja and Chrome directly don’t work.

However, with Dock applet I don’t have any problems.

This PC runs Ubuntu Mate 16.04.1, has an Intel E4500 cpu, 3 GB of RAM and a Nvidia GeForce 7600 GS with proprietary drivers.

Best regards!!

Weird problem. Try pulling it up in terminal and look for errors. First kill plank…

Code:
killall plank

then…

Code:
plank

1 Like

Hi @acutbal,

have you also run a full system update?:

1 Like

Hi,

Here is the output:
http://paste.ubuntu.com/20745325/

Regards and many thanks!! :grinning:

Hi!!
Thanks for the tip, but I do a “sudo apt update” everyday, so my system is updated.

Best regards and thanks!! :grinning:

1 Like

Btw, your output states “Missing key” but I have no idea how to fix it except to try the following.

Change your software sources download location and then run the following terminal command (Ctrl + Alt + t):

sudo apt-get update && sudo apt-get remove plank && sudo apt-get install plank

then restart and see if it fixes it!. :smiley:

1 Like

Hi acutbal

Using the /usr/share/plank/themes/Matte/dock.theme, I get the same output as you. A slew of warnings, but no errors. Also seems to work just fine despite all the warnings… Switching to another theme (ubuntu-mate) all I get is:

[email protected]:~$ plank
[WARN 13:42:27.714954] [Environment:161] XDG_SESSION_CLASS not set in this environment!
[WARN 13:42:27.785101] [Preferences:192] '/usr/share/plank/themes/Ubuntu-MATE/dock.theme' is read-only!
[WARN 13:42:28.071065] [SurfaceCache:196] Creating surface took WAY TOO LONG (33ms), enabled downscaling for this cache!

Still no matter which theme I run (tried them all) it runs just fine.

What system theme are you running? I wonder if there is a conflict. Try a different system theme.

As wolfman suggested, reinstalling plank is worth a shot. But I would use stronger medicine. There is a configuration file in your Home directory (hidden file) ~/.config/plank. Remove or rename that file and then…

sudo apt remove --purge plank && sudo apt install plank
1 Like

Hi!!

I can’t do that because the command also removes the ubuntu-mate-desktop meta package.

Best regards and thanks!!

Hi!!
Regardless which theme is enabled the result is the same, an erratic performance. Uninstall and reinstall Plank it’s not possible because the ubuntu-mate-desktop meta package is also removed

The first thing that I did when I saw the problem was deleting the hidden config file in my Home directory, but didn’t worked.

In addition, I’ve realised that new opened apps aren’t showed in the dock.

Thank you very much and best regards!! :grinning:

:confused:

[email protected]:~$ sudo apt remove --purge plank && sudo apt install plank
[sudo] password for yy2: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  plank*
0 upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
After this operation, 393 kB disk space will be freed.
Do you want to continue? [Y/n]

I’m not seeing this. Whats the terminal output of…

inxi -S

1 Like
  • This is the output:
    [email protected]:~$ sudo apt-get remove plank
    [sudo] password for albert:
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Los siguientes paquetes se ELIMINARÁN:
    plank ubuntu-mate-desktop
    0 actualizados, 0 nuevos se instalarán, 2 para eliminar y 0 no actualizados.
    Se liberarán 410 kB después de esta operación.
    ¿Desea continuar? [S/n]

  • After inxi s:
    [email protected]:~$ inxi s
    CPU~Dual core Intel Core2 Duo E4500 (-MCP-) speed~2194 MHz (max) Kernel~4.4.0-31-generic x86_64 Up~4:45 Mem~1134.9/3007.8MB HDD~160.0GB(63.6% used) Procs~195 Client~Shell inxi~2.2.35

  • And after inxi -S:
    [email protected]:~$ inxi -S
    System: Host: INTorre Kernel: 4.4.0-31-generic x86_64 (64 bit)
    Desktop: MATE 1.14.1 Distro: Ubuntu 16.04 xenial

Best regards!! :grinning:

Is this by chance a Mate install on top of Ubuntu (Unity)?

1 Like

A Ubuntu Mate 16.04 fresh install. But before I had installed Ubuntu 14.04.

Should I do a fresh install again? What laziness…

Best regards!!:grin:

Did you burn a DVD? If so, did you burn at low speed? Did you checksum the download?

1 Like

I’m not sure, but I think this occasion I burned the ISO into a DVD, with max speed. I didn’t checksum the download because I never do.

Do you think that can cause the issue with Plank?

Best regards!! :grin:

Bad burns can cause weird problems.

I usually keep burn speed down to 6 or 8x burn speed. A high speed burn can show as a good one, but still have problems.

And a corrupt download can do the same.

1 Like

In august I’m in holidays, perhaps I do a fresh install again. I am very lazy to have to reinstall it… :wink:

Best regards!! :grinning:

@anon42388993, maybe this is relevant?

I don’t think so, I’ve this issue from the beginning, before updating to Mate 1.14.1.

See also: