Error communicating with TPM chip

Not sure where this post fits best, but I am sure it will be moved if better suited elsewhere.
I want to install UM 21.04 on a HP Envy X360 15 (Intel 7 & Nvidia)
I boot with the USB ISO... but then I get:
"error communicating with TPM chip"
I then get a whole numbered list (all named 'Nouveau')
then a 'Failed To create Kernel channel' error
then it stalls. Have to reboot to windows.
I did search the web for solutions. Most have the error post install. I can't even get there...
I've tried disable/enable TPM in the bios. I've tried 'factory reset' also. Nothing seems to work.
Can someone here can contribute a solution?

Many thanks !


I still get the messages above but a line before referring to "initramfs unpacking failed" or similar
then it goes through a system check and finally
Was able to boot from USB by going with the 2nd option, i.e. low graphic
But now with no touchscreen, no touchpad working. Only mouse and keyboard.
Would like to solve that before installing
Also I guess I should change driver for NVidia. But don't know which of the 4 I'm offered to take, i.e. 450 or 460.
Help still appreciated

Maybe unrelated, but I had to reboot since I wanted to update my live USB. And now it doesn't show a choice of drivers in Software and Updates; no list. Still no pad and no touch.
and by the way, the USB has been made persistent and behaved well on another computer. Doesn't show as persistent on the Envy (!)

then... by reading on may sites, it seems that the issue may be RST-AHCI related. And nothing in the BIOS to change that.... If this is the actual issue. Still searching.

Help appreciated

Been able to boot the USB stick by proceeding with safe mode. But haven't installed on the HP Envy, yet. Want to understand the 'risks' is any.
Have connected a USD drive with a full UM install. Again proceeding with safe mode and re-booting normal. It did work. So can run UM from the external USB drive. Not perfect, but can while while a solution comes up.

I got to the end of my patience.
Instead of fighting with a dual boot impossible to get at
I decided to sweep everything and install UM using all the HP SSD
It did so. But initially with stalling at HP logo page; so no full boot. Tried a few tweaks... no use.
Did re-installed afresh from the USB (refreshed/updated again) and it installed.
Now with LVM and it works. Like on previous HP Spectre.
Something in the combination of Win/RST install on this laptop didn't like or didn't want the intrusion :stuck_out_tongue_winking_eye: