Error with package manager

I was working when I noticed a red icon on the top panel. I clicked on it and got this message:

An error occurred, please run package manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was: 'Error: Opening the cache (E:Couldn't create a temporary file to work with /var/lib/apt/lists us.archive.ubuntu.com_ubuntu_dists_Vivid_Release - mkstemp (30: read-only file system) E:The package lists or status file could not be parsed or opened.)'. This usually means that your installed packages have unmet dependancies.

Since it will not let me open the terminal, Caja, or anything, I'm going to restart and see what happens.

Any ideas? I'm running Ubuntu MATE 15.04 Beta 1 64-bit.

Here is a picture of the error message. Sorry for the crappy camera.

It says your file system is read-only :fearful:


I never had that problem before. Waht could be the problem?

I restarted it and installed updates. Once the updates were installed, I restarted again. Both times I restarted It looked like when the kernal started it went into emergency mode. It told me to check the log with journalctl -xb.

Here are some of the errors in the logfile. It easier than pasting the whole log file into Pastebin.

acpi LNXCPU:00: Invalid PBLK length [7]

ACPI PCC probe failed.

tpm_tis 00:05: A TPM error (7) occurred attempting to read a pcr value

fsck failed with error code 4.

Can’t find host Name or service not known
Can’t find host Name or service not known
Can’t find host Name or service not known
Can’t find host Name or service not known
Can’t find host Name or service not known (-2)
no servers can be used, exiting

nm_device_get_device_type: assertion ‘NM_IS_DEVICE (self)’

PAM unable to dlopen( /lib/security/pam_kwallet.s

PAM adding faulty module:

[1426604909.775168] [dns-manager/nm-dns-dnsmasq.c:

[pulseaudio] pid.c: Daemon already running.


restart in recovery mode and run DPKG (network cable required) per this guide:

For some reason, GRUB does not show up when I reboot.Can I do this with a LiveUSB?


I followed the instructions as best I could, but I had a hard time navigating around the recovery menu. The cursor/selector would not move up and down like I wanted it to do and sometimes text would appear on top of it. Is there any other way to run DPKG? I had Syncaptic fix broken packages.

Edit: I ran DPKG from the MATE Terminal and from the emergeny mode during boot. It still boots into emergency mode and I have to type exit to get to the Desktop. What is the problem?

Hi JB,

with all the other things you mention that aren’t working like the arrow keys for example, leads me to believe that you may have burnt your Ubuntu Mate disk too quickly if you used a disk to do your install!:

If you did a USB install, did you fully format the stick to FAT32?.

The only other option that I have for you is to try booting into recovery mode again and activate network; this time drop to "root" and type the following commands:

sudo dpkg --configure -a

and then:

sudo apt-get install -f

as I suspect that you basically have a damaged install and it may be possible to fix it with those commands!.

Once done, restart with Ctrl + Alt + Del, do not click on resume!.

Rgards Wolfman :grin:

I used SUSE Studio Imagewriter.

Did you pre-format the stick before you created the boot media or did you rely on the app to do so?.

I relied on the app.

I could not get to the root option on the menu. So when emergency mode came up and I ran the commands. Nothing installed. Maybe I should reinstall.


that is up to you, I do have a question though, is your keyboard a wireless KB?, I ask because Ubuntu doesn’t play nice with all of them in recovery mode!.

If you do a new install, make sure you format the USB stick with FAT32 first!.

Nope. It’s a USB keyboard.

Then in that case I suggest a fresh install and a complete new ISO image downloaded from a different location than the last one as that may also be a cause of the problem.

And don’'t forget, FORMAT THE USB STICK FIRST!. I wrote that bit just to make you aware of how important that is, good luck JB. :grin:

I’m not in the mood right now to do a total reinstall. Do you think I can get by with the system as it is for now?

Sure you can keep it running, what I would do is check your software sources settings and maybe change the software sources download location, it should be “Main” or most likely you have it set to the country where you installed which is standard, see the update guide link I posted earlier if you wish to try this approach.

Here is the link again, you’ll find it about halfway down:

@wolfman I’ve had some problems with this machine. As far as I can tell the BIOS was the problem. When I got it, the BIOS did not support drives of 2TB. I’ve updated the BIOS to fix that, but I did so after I install Ubuntu MATE. I think that might have been the problem. I’m formatting my USB drive at FAT32 now. I redownloaded UM Beta 1 from torrent and I’ll use UNetBootin to create a LiveUSB to install.

Hi JB,

good luck, this might interest you btw!:

I saw it before hand.

1 Like

@wolfman, I reinstalled a while a go and have been keeping up on updates, but this problems is rearing its head again. It told me there was a problem with the package manager because the apt folder could not be locked. I restarted with the idea that a reboot can fix a multitude of problems. (Alos, Caja would not open and screenshot would not work.) When it restarted, tt that went into emergency mode and I had to type "exit" to continue boot. Now, when I try to shut down it gets stuck and says

Error getting authority! Error initializing authority! Could not connect: No such file or directory

Here is another crappy photo