Ethernet unavailable after reboot

Greetings,

This one might end up being a little puzzling, it has me confused at least. In the house, I have 2 PCs available to me, with different hardware configurations. One of the two will continue to have a connection to my router after rebooting, one will not.

And the odd thing is – the one that does not does not display this behaviour when using Windows. The other one will have a fine connection irrelevant of the OS.

Even stranger, this behaviour of being unable to land a connection is across different distributions and across a wide range of kernel versions but still, only when using Linux.

Bringing the interface down and back up via ifconfig does not to resolve it. In fact, the only thing that resolves it is simply shutting the machine down completely (shutdown -P now). And when the connection is there, it is fine. Flawless, no trouble reaching my max Internet speed at all. Amazing latency, etc, etc. So, no hardware support issues outside of requiring a “cold” boot.

Edit 1:

[quote=“BrokenCanoe, post:2, topic:13320”]if there are any PXE or WoL timer events set[/quote]None.

Edit 2:
Disabling DHCP has no effect either.

TL;DR:

  • No ethernet after shutdown -r now
  • Perfectly fine ethernet after shutdown -P now
  • Only when using Linux
1 Like

That’s definitely odd!

Take a look at your BIOS/UEFI interface and see if there are any PXE or WoL timer events set. Ideally disabling wake on Lan events should at least rule out preservation of connection state.

[quote=“BrokenCanoe, post:2, topic:13320”]if there are any PXE or WoL timer events set[/quote]None.

For the record and maybe I should put this in the first post – Neither does it matter what I am connecting to. Originally I had a double router setup but one of the 2 routers died on me so now I’m behind the one. And the behaviour persists.

What I haven’t tried though is not using DHCP. Going to try that now.

Hallo

Are you “dual-booting” Linux and Windoze on “made-for-Windoze” hardware?

I gave up dual booting a few years back, I found it to be more trouble than it was worth. If I need 2-in-1 I virtualise one of the OSs. That might not be an option for everyone though.

Also, over the decades I’ve lost faith in “re-booting” and “network-connectivity”. My experience has led me to use full shutdown, then a fresh start as being the best way out of most such problems.

Not being a “network-savvy” person, this is my personal “line-in-the-sand”. Oh, and I avoid “wireless” like the plague that it is becoming. That one is easy to explain, biological organisms and magnetic fields - there are tolerances, and they will (are just beginning to) be shown to be lower that we suspect. :evergreen_tree: :penguin: :evergreen_tree: :penguin: :evergreen_tree: :penguin: :slight_smile:

[quote=“alpinejohn, post:4, topic:13320”]Are you “dual-booting” Linux and Windoze on “made-for-Windoze” hardware?[/quote]For various reasons, most importantly and ironically hardware support I have completely given up on Windows. I will not accept being forced to purchase a new version of Windows whenever a new generation of hardware is released and finds its way into the home.

I pop in my trusty Windows 7 DVD and, behold, it doesn’t even recognize half the hardware in this box. And it’s a very simple box. APU, no GPU, no SSD. I pop in my Live Ubuntu MATE USB and everything works!

So, no, not dualbooting.

And obviously it’s not wireless, I did say Ethernet. So, cabled. Being a gamer kind of makes that one a given in my case. No wireless at all connected to this PC. Not even a single bluetooth device. All cables here. With the proverbial cable spaghetti to show it. :wink: