Failed to Update Cache check your internet connection

Trying to update source list because when I try to download additional themes through the welcome screen it says package does not exist. Running 16.04. Also I tried switching from US server to Main and no difference.

Edit: Now it’s failing to download repository information from the software updater. Weird.

I think the following error I’m getting is related to your problem:

Err:22 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04 Release.gpg
KEYEXPIRED 1496576244

https://github.com/horst3180 includes: arc-theme, vertex-theme and others.

Edit: try running “sudo apt update” from a terminal to see if you get the same error

I don’t have that error. Also I shutdown and started back up and now my main software updater works but still can’t install the theme from welcome or update cache. However I did install numix through terminal and the icons show up but not the main system or whatever.

Hallo

I’ve had that problem too for three or four days now, although this morning it worked.

Each time it happened I used a terminal to run the update instead - that worked without any problems.

This behaviour could be a little unsettling for users who don’t venture into the command line.