Freezing randomly

Idk, my keyboard mouse everything was frozen.

Freezing like that sounds like you ran out of ram or CPU(which you shouldn't happen with that CPU nor with that amount of ram, how many tabs do you have open in firefox at a time? If you wait long enough does it respond? Have you tried any other versions of Ubuntu MATE? Does it just lock up instantly, or does it slowly lock up(like become very slow to respond, then the mouse slows and then quits, etc)? How much ram is it using at startup?

1 Like

I have a similar situation to Rohan Jnr's. However, it is on an elderly wreck of a machine, built in 2003! Athlon64 2233 Mhz CPU with 2 Gb of RAM.

The seizing up is entirely random and can occur before any programs are opened. Sometimes the REISUB trick works; othertimes she needs rebooted.

I figured that I should be grateful that a 2003 machine is still working, but it's handy having a seperate computer handling the music.

The 2014 machine sitting right next to it and running exactly the same Ubuntu MATE 18.04 does not exhibit the same behaviour (touch wood).

Mate performance is generally really good, very fast and I actully like it. The freezes just happened all of a sudden and all happened when I was playing YouTube /audio. 2 times. The audio would just loop around continuously.its been almost 4 hours I have been using it now and no freeze and I'm scared to open any audio and btw my machine is 3 years old so I'm wondering if it has anything to do with audio stuff. Should I check the logs or something?

And there r segfaults in my kernal.log, does that have to do anything?

Hi,
Would you please paste some rows of those segfaults in log?
Perhaps it could help to proceed in investigation.
I think, it can be either a hardware related issue or bug in a kernel module (e.g audio driver) of your audio or video device. Also it can be a bug in your browser. Please try to turn off hardware acceleration in browser to see if it solves the problem.

https://pastebin.com/tETcLpS0
go here and you will see the segfaults which i copy pasted from my kernal log file.

Yeah at this point I would try using just local audio and see if it does it, and if it doesn't try audio in the browser, that will hopefully help narrow it down farther, also make sure you are fully updated, I'm no expert just trying to help. :grinning:

Hello,

In order to get a better picture and not just guessing at the problem. Please post the results of the following:

inxi-Fxxz and then post the outcomes of the commands in this tutorial. Only with better information can someone give you a solution. Also I'm sure if you search this forum on freezing, you will see many resolution that may be posted.

Thanks for sharing the log.
After reading it and doing some searching, it seems, it is not related to audio but rather to graphic subsystem. It would be nice to see Xorg.0.log too after a crash. I think we would see related information in there.

However, if you don't need to keep 18.04 and want to eliminate problem fast, as a shortcut, I would suggest to upgrade to 19.04.

it dosent let me upload the log file here and content is too much for paste bin, are u on discord or something or ur email to which i can send it too?

You can upload it to my Dropbox:
https://www.dropbox.com/request/qQ3tZG98UzmEQsvzDJHf

done uplaoding files to our dopbox

Thanks, checking them, please hold on...

Unfortunately there is nothing relevant in the logs.
I can see there are app-menu-mate and mate-panel segfaults and then a hole in the timestamps.
I assume those are the points when system were hanging and you reseted it.
Segfault informations led me to older bugs prior to Ubunto 18.04, so we can say they fixed most of them until now. I'm afraid, you ran into a bug not discovered yet, but I cannot rule it out, that there can be hardware issue too.
I see two possibilities right now. If you upgrade your system to 19.04 (or wait a bit for 19.10) and problem will be gone, then bingo, you won. If problem is still active after upgrade, then hw error confirmed.
If you insist to 18.04 lts, then I suggest to open a bug report at Ubuntu Launchpad.

This is all I can respond now, but perhaps we have other guys here who have ideas.

Okay, thanks for looking into it!

just encountered another freeze while watching youtube :confused:
one of my friend was having the same issue too with mate, i.e graphic drivers. he was having issues with the integrated intel graphics.I have integrated HD graphics too.
https://pastebin.com/zq9p1cA4
This is the log file just after turing on my pc after a hard shut down.

This is reminiscent of the C-state bug Intel caused in their i915 driver many years ago and never fixed, but I think your CPU shouldn't suffer from it. (Sorry, it's late and I'm too tired to go through ARK right now).
I'm guessing you don't know how to edit GRUB commands, and you definitely should not go down this road until you've explored all the other options, but if that time comes "intel_idle.max_cstate=1" is the magic setting.

1 Like

okay i did it cuz my pc froze again when i was in an important voice chat

Good evening,
I also face the same problem. I would be grateful if anyone could help.
Best
Yannis

Here are the results of the inxi-Fxxz

System:
Kernel: 5.0.0-27-generic x86_64 bits: 64 compiler: gcc v: 8.3.0
Desktop: MATE 1.20.4 info: mate-panel, plank, vala-panel wm: marco 1.20.3
dm: LightDM 1.28.0 Distro: Ubuntu 19.04 (Disco Dingo)
Machine:
Type: Laptop System: HP product: HP 240 G4 Notebook PC
v: Type1ProductConfigId serial: Chassis: type: 10
serial:
Mobo: HP model: 8131 v: KBC Version 30.0B serial: UEFI: Insyde
v: F.22 date: 11/11/2016
Battery:
ID-1: BAT0 charge: 41.2 Wh condition: 41.2/41.2 Wh (100%) volts: 16.6/14.6
model: Hewlett-Packard Primary type: Li-ion serial: status: Full
CPU:
Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: CC
L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200
Speed: 500 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 500 2: 500
3: 500 4: 500
Vulnerabilities: Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1916
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
compositor: marco v: 1.20.3 resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
v: 4.5 Mesa 19.0.8 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70
Sound Server: ALSA v: k5.0.0-27-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 01:00.0
chip ID: 10ec:8168
IF: enp1s0 state: down mac:
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000
bus ID: 02:00.0 chip ID: 10ec:b723
IF: wlp2s0 state: up mac:
Drives:
Local Storage: total: 465.76 GiB used: 76.12 GiB (16.3%)
ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-60VHAT0
size: 465.76 GiB block size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: 1A01 scheme: GPT
Partition:
ID-1: / raw size: 13.67 GiB size: 13.39 GiB (97.97%)
used: 9.19 GiB (68.6%) fs: ext4 dev: /dev/sda6
ID-2: /home raw size: 210.25 GiB size: 205.95 GiB (97.96%)
used: 66.87 GiB (32.5%) fs: ext4 dev: /dev/sda7
Sensors:
System Temperatures: cpu: 42.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 215 Uptime: 32m Memory: 3.77 GiB used: 2.59 GiB (68.6%)
Init: systemd v: 240 runlevel: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: bash
v: 5.0.3 running in: mate-terminal inxi: 3.0.33