Geforce 840M and Cuda 8.0 RC Installation


I am trying to install Cuda 8.0 RC on my laptop with nvidia Geforce 840M. I know there are many threads related to nvidia driver installation, and i tried almost all but none work for me. (maybe i am doing some basic mistake). I tried Cuda 7.5 also but no success.

Kindly suggest me some fix for this.

Thank you.

Regards, Pachauri

Hi @kb.pachauri,

see this guide and report back if it solves the problem for you!:

Thank you very much for your response.

As can be seen from my first snapshot, additional driver shows nvidia-361(proprietary) installed,
but when i try to check it using glxinfo | grep "OpenGL Version" it shows still intel GPU and driver is in

When i run cuda devicequery it exit with mesage "nvidia_361_uvm" is not loaded and when i try to load it
it message "Required key not available". Attached snapshot for both.

Not sure whats going on.. :(.

Regards, Pachauri

Hi @kb.pachauri,

try removing all the Nvidia packages and restart, then install the Nvidia drivers first, restart once more and then see it runs okay and once it is up and running; install the Cuda packages!. :thumbsup:

Have you done a full system update?:

Hi @wolfman,

Thank you, and sorry i got busy in other issues, so could not try.

First, Its fresh installation of ubuntu mate 16.04.
I tried removing and again installing, Still no success. On Window10 CUDA works fine.

Actually when i tried to install nvidia driver, after driver module is failed to load.
So i tried downloading exact GeForce840M deriver from nvidia site, but still after
installation it says it could not load module.

Thank you


how did you install and did you follow this advice?:

Have you done a full system update:

I do not run cuda, but here are my findings. First the most recent related issue.

And this about modprobe (mint was as close as I got).

This is dated

I made bootable USB stick using Rufus and than installed it. During installation time also, i checked network options so that all latest updates also get installed.


try running the following terminal (Ctrl + Alt + t) command and restart after running it!:

sudo apt-get update && sudo apt-get remove nvidia-361 && sudo apt-get install nvidia-361