GIMP on Mac G5 running MATE

You said earlier GIMP produces GEGL errors from the terminal, – indicating the GEGL library is part (or just) the problem. Have you got any full terminal output for us to investigate?

GIMP should work on PowerPCs, it could be the case of corrupt packages or some strange problem running on the Mac G5.

I took a screenshot after running gimp in terminal. I will try to insert it. There were many lines like those involving GEGL-gegl-operation.c that I can send if necessary.

I discovered that GIMP is (has always been?) running. By accident, I tried opening a jpeg file with Ctrl-O. A window appeared that allowed me to choose a file. By choosing KEEP the embedded profile, I could see and edit the picture. I could save/export it as normal.

Now, if I can figure out how to get Synaptic to work.

I tried to download Darktable through the Ubuntu Software Center but was told it was not available (even though it showed in the Software Center and even allowed me to click on Install.

Hi @tomi,

these might help you: