Google Chrome ppa

This is my first post here since I'm new user of Ubuntu Mate. I have been doing some distro hopping in recent times since I upgraded my computer to Haswell i7, and my previous OS has some issues with graphic drivers (FreeBSD).

So I'm learning "linux ways", and after some testing of other distros, I decided to stick with you guys. Experience is super slick, love how things just work. But here comes my first observation. I noticed some error logs while updating:

W:Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Now, I'm pretty sure I did not messed with ppa entries at all, but if I try to open that url in error, it gives me back 404. Or did google change url and I just need to enter new path?

Best regards

Hmm.. now that I posted this ant tried to open link it works..
Here is my sources list:

There is an answer and explanation here…

1 Like

Solved by:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list" "/opt/google/chrome/cron/google-chrome"

And then apt-get update does not complain any more

Thanks for the tip @django

2 Likes

OMGUbuntu! also featured this in one of their articles:

This happened to me a couple of weeks ago. I haven’t had time to look into it. Please to see that there is a simple solution.
However, my Ubuntu is 64-bit. I am now wondering if I have installed a 32-bit Chrome.

When chrome dropped 32bit it broke the 64bit source. The above sed command adds the 64bit back to your sources. Although I am not sure why the cron job needs to be added. Maybe samob can explain.

1 Like

Thanks. I’ll sort that tonight.

I just "extracted" most voted solution on link that django posted previously

I too have 64 bit OS, and I checked my Chrome is also 64 bit version.

1 Like

I’ll use the command you specified earlier. That should work.

UPDATE

That worked a treat. Many thanks @samob