GPA not working

Hi,

Just installed GPA and it doesnt work i get this error each time,

The GPGME library returned an unexpected error at keytable.c:150. The error was:

Unsupported certificate"

anyways i click close and the manager works sort of like i create a key dont have an option for 4096 bit, i create it but i cant encrypt or decrypt like the key is greyed out so i try to open againa nd now my key is not even on the list! its so buggy can any one help me please?

Hi,

have you checked out their homepage and the FAQ’s?:

https://www.gnupg.org/related_software/gpa/

hi,

ok i get source and run ./configure i get this error

checking where the gettext function comes from… libc
checking for pkg-config… /usr/bin/pkg-config
checking for GTK+ - version >= 2.10.0… Package gtk±2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk±2.0.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘gtk±2.0’ found
no
*** Could not run GTK+ test program, checking why…
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: Cannot find GTK+ 2.0

Hi,

try these packages as I am not sure which one you need:

http://pkgs.org/ubuntu-15.10/ubuntu-main-amd64/gtk2-engines-murrine_0.98.2-0ubuntu2_amd64.deb.html

http://pkgs.org/ubuntu-15.10/ubuntu-main-i386/gtk2-engines-murrine_0.98.2-0ubuntu2_i386.deb.html

http://pkgs.org/ubuntu-15.10/ubuntu-universe-amd64/gtk2-engines-aurora_1.5.1-4_amd64.deb.html

http://pkgs.org/ubuntu-15.10/ubuntu-universe-i386/gtk2-engines-aurora_1.5.1-4_i386.deb.html

Select either the 64 or 32 bit packages of both types and download and install them and see if that helps!. :smiley:

hey, i should also mention i am on raspi 2 and i installed those packages same error, :frowning:

checking for pkg-config… /usr/bin/pkg-config
checking for GTK+ - version >= 2.10.0… Package gtk±2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk±2.0.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘gtk±2.0’ found
no
*** Could not run GTK+ test program, checking why…
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: Cannot find GTK+ 2.0

Sorry!, I didn’t even notice you were on a Raspberry. :frowning:

This might help?:

http://www.raspberry-projects.com/pi/programming-in-c/gui-programming-in-c/gtk/installing-gtk

hi,

i did that and still had the same error, could some one please try compiling it them selves and tell me if it worked or fix the current bug in the repos?

Hi,

try running the following terminal commands and see if that helps!:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.