Graphics/screens problems

Hi all,

I have installed Ubuntu Mate in a Thinkpad L580. As expected, everything works except the fingerprint reader.

However, when scrolling fast a website (or text editor) it does not work smoothly. It is more evident when I play a video on the TV via HDMI, where I can see the same “line”. It is like the screen doesn’t refresh the image fast enough.

I don’t know much about Linux, but I guess this could be related with the graphics card? I think is properly configured:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07) (prog-if 00 [VGA controller])
Subsystem: Lenovo UHD Graphics 620
Flags: bus master, fast devsel, latency 0, IRQ 137
Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at e000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [40] Vendor Specific Information: Len=0c <?>
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [100] Process Address Space ID (PASID)
Capabilities: [200] Address Translation Service (ATS)
Capabilities: [300] Page Request Interface (PRI)
Kernel driver in use: i915
Kernel modules: i915

I’m using release 18.04.1 LTS (Bionic Beaver) 64-bit

Any suggestion?

Thanks in advance,


You have an Intel GPU, the only driver available is FOSS and included in the kernel. I’m not sure there’s a way to upgrade it (Intel had a tool for this but I’m not sure it’s still available and/or handles Ubuntu 18.04). In any case, I doubt that perfs issues would be fixed by an update, as the driver in 18.04 is not that old.

If your issue is only tearing and not bad perfs, there are two things that you can try:

  1. Change the compositor. Launch MATE Tweak from the Control Center, go to the Windows tab and you should see an option for the window manager to use. By default, it’s Marco with its own compositor, I think. Try Marco with Compton (or even Marco with no compositor) and check if the issue happen again.

  2. If it still does, you can try to setup the X server to force vsync. Launch Pluma as root to edit a config file:

    sudo pluma /usr/share/X11/xorg.conf.d/20-intel_flicker_fix.conf

In it, put this and save:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TripleBuffer" "true"
  Option      "TearFree"     "true"

Reboot and check if it fixes the issue. If it doesn’t, you can delete the file:

sudo rm /usr/share/X11/xorg.conf.d/20-intel_flicker_fix.conf

If for some reason, after adding the file your system boots to a black screen (no display), you can switch to a TTY with ctrl + alt + F1 (or F2, F3…), log in the console, delete the file and reboot with sudo reboot to get back to the initial situation.

If none of these fix the issue, I don’t really have an idea.

Hi terzag,

Thanks a lot for your help and detailed explanation.I am using Marco with Compton now and the screen tearing has disappeared.

Ok. In case you have the same issue again in a different context, e.g. with fullscreen apps (like games), keep the second solution at hand, as it would enable vsync system-wide, not only on the desktop (Compton disables itself with fullscreen apps).