Grub error after installing UM 20.04

There is something strange when I try to install UM 20.04 on a system that had UM 18.04 installed. System 1 only accepted a start with sign in, and I ended up with installing LM 20. System 2, a Win 10 system worked fine out of the box. Now, being on my main system, I get UM 20.04 installed but Grub doesn’t work.


If I press Tab key I get a list of what I could do.

I have no idea what’s going on.
I’m just installing LM 20 hoping it will install a new Grub boot. (Update: it works fine). It would be devastating if that ASUS laptop would fail to work because its the only one that has got a good monitor profile for editing images.
Do you know what the problem is?

Like on system 1, I had no sign in and Secure Boot was disabled if that matters.

Update: installing LM did the trick. I then installed from a new UM 20.04.1 DVD and is has restarted so far. Just updated and a new start also worked.
Thanks goddess I have come away :grinning:

I :heart: My Ubuntu Mate. It would have been too much of a compromise if I had to work with LM.

Glad you found a solution . . . I agree that U-MATE is a good choice, but this problem with grub, where, the solution is to install another OS . . . is a "work around" . . . . I again run into grub issues in my 20.10 system today . . . it keeps happening and should actually be "fixed"?? I'll be posting another thread over in Devel . . . .

Thanks. I think Grub has got a problem when the same distribution was already installed. It doesn’t overwrite the old Grub, seems only to update some parts, but nothing works at the end. In contrast to system 1 which launched fine but had that strange problem with showing the “Enter Password” window, on my laptop, it didn’t launch at all. So, I had to use another Grub loader, and thanks god, it worked.

I’m not fully out of the woods as I changed to Xorg, because on none of the 3 systems, the NVidea driver seems to work. There is always an error message after each start. I will see tomorrow morning if the Xorg change went through.

Yes, on the problems with grub, especially if you have more than just ubuntu installed. I've had numerous repeats on upgrading grub via ubuntu and it wipes everybody else except . . . itself??? I've had to boot using SuperGrub2 disk as the bootloader to get over to Tumbleweed and then use their method to update "grub2" . . . . I don't know if ubuntu is still using "grub" or if they haven't figured out how to deal with EFI boot . . . but the problem is not new and it has affected quite a few people . . . still.

Xorg should be the "standard option" . . . I believe I've got that going . . . . But I have an Nvidia what GT780?? card in my '12 Mac Pro . . . and largely in linux I'm not using the nvidia drivers, because their drivers weren't keeping pace with linux upgrades . . . so in some systems I'm using "nouveau" and it's fine and crispy . . . visually. And, in TW a guy on a forum suggested not even using nouveau, but to use "default" . . . I think by "not accepting nouveau" and that driver is also fine . . . . Over in OSX 10.13 I have the proprietary drivers installed . . . seems OK. But, then I believe in 10.14 Apple and Nvidia started banging heads so there are no drivers from Nvidia for newer OSX.

The problem I have with using Xorg is that when I restart the system as I have done now, then no driver at all is in use and everything is greyed out. I'm just here in the forum to find out if that can be fixed.

???? From what you are showing here you have a "manually installed driver"??? But did you try checking the third line, the one that has "nouveau" in it? Actually you could probably check any of those "Nvidia" options and click "apply changes" and you should be "OK"??

If you want to know what video driver is in use, did you try to run "lsmod" in the console?? It should list the "modules" that are in use for drivers, and under or next to "video" it should have something listed?? I'm forgetting what the default video driver is for linux, but even that driver should be working???

I might be "figuring out" what you are saying now . . . you can't click on any of those options, even if you do click, nothing changes?? OK, another GUI way to go is to go to synaptic package manager, and see if you can find any of those drivers there, and use synaptic to try to install it.

Or, back in the console you should be able to run "sudo apt install nouveau" and see if that goes through. I think it's a little more complicated to add "nvidia" . . . but if you wanted nvidia you could try "sudo apt install nvidia-driver-390" . . . (which is what is showing up in the add'l drivers) and see if it shows a bunch of packages to install . . . .

Try some of that stuff and see what shows up . . . it seems like if you are able to show a screenshot of the Software & Updates page you do have "video" driver . . . ???? Have you run through "sudo apt update && sudo apt dist-upgrade" a few times?? Often times after an install if you run through an apt update/upgrade a few times the system "figures out what you want and installs it" . . . . Linux kind of has a "6th sense" about itself . . . be patient with it . . . don't worry, etc.

I found later on my own entry about this topic that I had already with UM 18.04.

The problem is not that I hadn't installed a driver, but being in that part of Software and Updates obviously causes trouble - maybe if we have two graphic cards (NVidia and onboard card). Once I change to Xorg, the system doesn't recognise the NVidia card, and removes all drivers.

I quickly installed UM 20.04 for the 4th time :slight_smile: and I have now finished the final touches.

Glad you figured it out . . . I don't have any experience with having two video cards . . . . Not sure why when you say "Xorg" (assuming you mean nouveau?) why that would "remove all drivers"?? Usually drivers installed are there until you manually remove them?? That might be a "bug"?????

I suppose it affects machines with 2 cards because I did last month the same change in 20.04 on a system with 1 card and it worked fine. 18.04 had the same problem BTW. Reinstalling the system is the only way to get it repaired.
Laptops have often 2 cards, the onboard for the simple tasks, and the NVidea for the graphics stuff.

I do know that "more than one card" is not "new" in the tech world . . . but I don't know enough about linux to know whether "it" can scope out the two card hardware and set itself up for both . . . . OR, as you suggest, it sets it up for the basic hardware and then "removes" the other drivers . . . ??

From messing around with getting "nvidia" added and then removed from various machines in trying to get basic "suspend" functionality, I do know that "nvidia" gets added to the repos . . . and then the meta-packages have to be added in . . . .

But, problem is that nvidia isn't retro-updating linux for anything they consider to be "old" . . . which might be a few months . . . . I just found it to make no difference in linux to have nvidia or nouveau drivers, but then I'm not doing much in the way of advanced graphics . . . .