Grub / MBR Confusion

This is just a question to better my understanding of Grub and MBR. A little history first.

This link is about an issue where my hard drive became unbootable after using a new backup livecd program, Active@ LiveCD. I became suspicious of Active@ LiveCD since it failed restoring my drive with an error ”failed to create partition at sector 1” and was then offered the option to fix the issue it if I bought the upgraded version. I exited and ran my normal backup livecd (ReDo). Although there were no errors my system was unbootable. I resolved the issue by botting into Mate livecd and running boot-repair. The repair results are posted here. I have tried reading about Grubs and MBR, but I don’t think I fully comprehend.

So my question, is there a location on the disk separate from the OS partitions that direct the system to the Grub? If so, is this location an actual partition? Does the MBR exist there. I just don’t see such a partition using Gparted.

I know many don’t like answering these type of questions. But any insight is appreciated, even if it is only if you agree or not with my theory that Active@ LiveCD made my drive unbootable (intentional or unintentional by user error). Thanks.

This may help you.

If I understand correctly, it tells me there is a location in the beginning of the disk that contains a GPT or MBR or both. I would assume since I installed 16.04 on a never used SSD, I would have a GPT. Running the following commands:

$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: not present


Found invalid GPT and valid MBR; converting MBR to GPT format
in memory.


Disk /dev/sda: 468862128 sectors, 223.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 50F5BA91-76D4-4118-8235-48CE36C4796C
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 468862094
Partitions will be aligned on 2048-sector boundaries
Total free space is 5229 sectors (2.6 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 452282367 215.7 GiB 8300 Linux filesystem
5 452284416 468860927 7.9 GiB 8200 Linux swap

$ sudo parted /dev/sda print | grep -i '^Partition Table'
Partition Table: msdos

Which still leads me to believe that Active@ LiveCD messed with the sectors preceding the first partition (boot sector) where my ReDo backup program only saves and restores partitions.

Did you use Redo and back up your entire primary partition to another hard drive ?

What happened when you tried to restore your primary partition using Redo?

I am trying to get more fact so I can understand what may be going on. :slight_smile:

ReDo copied all partitions on disk. ReDo restored all partitions to the same disk.

The time I experienced the failure, I first made a copy of all partitions using ReDo, then made a copy of all partitions with Active@ LiveCD. No errors with either process. Then I first restored to the same disk using Active@ LiveCD, which failed with an error "failed to create partition at sector 1". I then restored with ReDo, no errors, but system would not boot. I can see all fles and partitions, it just would not boot. After running boot-repair from an Ubuntu livecd, the system was bootable again. I have used ReDo successfully since making the system bootable again.

That's good. Glad to see everything is working o.k.

Thanks. But I was not looking for a solution to fix the disk as it was already found. I was just trying to understand what went wrong and maybe get some validation of my thoughts of what went wrong. In fewest words; I now understand there is a location in the beginning of the disk that contains a GPT or MBR or both also known as the boot sector and it seems to me that ReDo does not copy or restore in the boot sectors. For some reason Active@ LiveCD did adversely change the boot sectors (either intentionally or user error)