HDMI/TV suggestion for next release

video

#1

I would like to see in the next release auto detect HDMI like when you have your TV connected to your computer. I have to manually do it every time and change the resolution to make the picture right on my TV and then do the same when I'm switching back to laptop only display. I mean it detects my TV but my laptop display doesn't show up on my TV until I change it to mirrored displays. Anyways just a suggestion. Not sure if this is the right section for this post so if not then please move it


#2

But it already works like that, unless I misunderstood.

Multi screen layouts are saved after a first setup, so you need not to do it every time.


#3

That is correct. That is how I have mine set up.


#4

Well for some reason mine doesn't save. I have to manually do it every time so I don't know


#5

I am not an expert in that field, but my guess is that the culprit could be your TV.

Anyway, the config file for screen layouts is in $HOME/.config/monitors.xml.

Try it to delete it, if it exists, and see if configuring your TV does recreate one.

You can observe that it is a simple XML file, with a section for each connected screen.

Each screen is recognized with a product ID and a serial number. It could be that your TV does not send a valid ID over HDMI, or that it is random at every connection. That would explain your issue.


#6

Ok thanks I'll give it a shot


#7

I looked but can't find the location for that file


#8

Not clear : can't you find the location or the file?

Please type this in a terminal and show the output:

ls -la $HOME/.config/monitors.xml

#9

The output list is too long for me to copy from my phone to here from the terminal on my laptop. I'll have to wait until I get my internet back next month to do this so I can copy and paste from the terminal on my laptop to the forum. Thanks


#10


I have the same issue and have yet to resolve. Recently I received this post as a potential fix but have not tried yet. I will also try deleting monitors.xml.

The other issue I have is when the PC screen goes dark, the HDMI settings change as well.


#11

This is not a pulse audio issue on my end. I'm talking about Ubuntu MATE auto detecting the right resolution from my laptop to my TV. Windows 10 does it automatically and I don't have to change a thing. I have a dual boot system for now until I can get all these technical issues resolved. My audio I have routed to my surround sound speakers and they work fine. Its just the video aspect I'm trying to figure out so I don't have to manually change it every time I watch a movie


#12

Sorry. I misunderstood. I guess I did not need to delete monitors.xml.

I also had similar video issue on my Samsung TV when I first installed 18.04, but resolved it by setting my video setting on my TV for this particular HDMI port as "Native" vice one of the many other options. I have not used my laptop on any other TV, so not familiar with other TVs similar setting. I also have to power the TV on/off for the HDMI to be recognized, but I assume that was a TV issue. I still have an issue if the laptop screen is allowed to go black (screen saver mode). I need to reestablish the connection again by cycling the TV power.


#13

Do you have the TV set as the primary monitor? I'm using Mint. If I set TV as primary, it works every time it is attached. If the laptop is set to primary, the settings do not get saved for HDMI. Just a thought


#14

TV is not set as the primary monitor for me.


#15

Thanks I'll try that! I had laptop set to primary


#16

Open a terminal & type pulseaudio -k...it'll kick on the HDMI for you. Takes about 15 seconds. I don't mind it...