Help save my venerable G4 iMac! [SOLVED]


#21

Do you have a blacklist file in /etc/modeprobe.d? Check

ls /etc/modprobe.d

You might have a file called “blacklist.local.conf” – if not you might have to create one.


#22

apparently not:

alsa-base.conf blacklist-framebuffer.conf blacklist-watchdog.conf
blacklist-ath_pci.conf blacklist-modem.conf fbdev-blacklist.conf
blacklist.conf blacklist-oss.conf iwlwifi.conf
blacklist-firewire.conf blacklist-rare-network.conf mlx4.conf


#23

OK Try using Snapper first -

You will need to create a blacklist file then:

sudo pluma /etc/modprobe.d/blacklist.conf.local

with contents:

blacklist snd-aoa-codec-tas
blacklist snd-aoa-fabric-layout
blacklist snd-aoa-i2sbus
blacklist snd-aoa-soundbus
blacklist snd-aoa

And append “snd-powermac” to the list of modules in /etc/modules:

sudo pluma /etc/modules

Then, reboot (and cross your fingers:)

djb


#24

djb–

Forgive the delay in responding; apparently one can only post so many times in the first day of community membership and I’d reached the limit.

I did as you advised and rebooted, but still no sound.

Unwilling to give up, I opened a terminal and typed Alsamixer, which I found had re-muted the Master, so I unmuted it; no change. Next I played with pretty much every column in Alsamixer, and at some point, SOUND!!! I’m not even sure which one did the trick.

Rebooting another time, the sound “just worked” without having to delve to the command line. Let’s call that a complete victory!

I’m very grateful for your help! I’ve retitled the thread to end in “[SOLVED]” but if there’s anything else I can do to recognize your consideration please let me know.

–Kim


#25

Just glad it worked. Us old folks won’t be around too much longer:)
djb